Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am getting this message every time I start

I've read this tech note, but neither checkbox is selected.

I've run Keychain First Aid, and no problems were found.

How do I fix in Lion that keeps asking for keychain password?

UPDATE: Thanks everyone for the help.. I finally deleted the Keychain prefs. Re-entered passwords as required, and that worked.

share|improve this question
I've experienced the same with Teamviewer. No solution still. – Hoshts Aug 17 '12 at 8:29
What does codesign -vv /Applications/ return? – user495470 Aug 17 '12 at 13:32
Thanks Lri, I will try this on Sunday, when I visit this client again. – David DelMonte Aug 17 '12 at 15:48
responds: valid on disk, satisfies its Designated Requirement – David DelMonte Aug 19 '12 at 15:11

Quit Mail. Open Keychain Access (Applications > Utilities). Select your Login keychain. Run Keychain First Aid (Keychain Access menu > Keychain First Aid).

Put in your password and run a verify. If there's any red, select repair and run it. Run another verify to make sure the errors are fixed.

Delete all of your mail entries. In the search bar, try putting in things like "pop," "imap", "gmail", even your email address. Quit Keychain Access.

Launch Mail. Get into the preferences (Mail menu > Preferences > Accounts). Fill in the passwords for each of your accounts. Also, go to the SMTP/Outgoing server menu, and edit. Fill in the passwords there as well. Close and save. Exit mail.

Launch mail. Make sure it retrieves mail properly. Send test emails to make sure it sends properly.


share|improve this answer
in the question, I wrote that I have tested Keychain. No issues. The computer uses iCloud so no POP/IMAP. It does receive mail ok. Other ideas are welcome. I'm not sure why you got upvoted though.. – David DelMonte Aug 17 '12 at 15:47
Why the hostility? I may have been upvoted because this is a good start to repairing password remembering problems. That aside: OK, instead of searching for those strings, search for iCloud, or "@me", or "@mac". Am I dumbing this down too much for you? Basically, get rid of any keychain entries that are related to the email address you're having problems with. Does any other application have password issues? If not, the next logical step would be to blow away mail prefs. – Harv Aug 17 '12 at 16:14
Apologies Harv. Long Day. Thanks for the follow up. I'll look at it on Sunday. – David DelMonte Aug 18 '12 at 4:02
+1 for putting up with me, and still offering ideas. – David DelMonte Aug 18 '12 at 4:49
@GeneJ I wouldn't write it off so easily. You're right: in my experience the Office suite tends to act a bit funny in general, but I have seen Outlook remember passwords properly. Keep digging. – Harv Nov 27 '12 at 18:55
up vote 2 down vote accepted

What worked for me was deleting the Keychain prefs. Re-entered passwords as required, and that worked. phew!

share|improve this answer

@Hoshts I have just experienced the same problem with TeamViewer. In my case, it was a problem with the proxy. In the Preferences, I had to manually set the proxy settings (instead of Use webbrowser proxy) and it worked fine.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.