Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

How can I change the username that is used to connect to a SharePoint site in Microsoft Document Connection. When I try to connect to a site, it's showing the authentication screen, but only allows me to enter the password. The username is defaulted to my Mac login user, but I can't change it (it's greyed out). Connecting using these credentials does not work, it always displays "You do not have permission to connect".

For a successful connection, I think I have to prefix my username with the name of our Windows domain, e.g. DOMAIN\username. Unfortunately, Microsoft Document Connection does not allow me to do that.

Any ideas on how I can change the username?

share|improve this question

2 Answers 2

up vote 3 down vote accepted

I had this same problem, and found the fix.

Our problem was that the company had migrated to a new domain, with all our usernames etc intact. So our old username (without a domain specified) was in the MDC Preferences, but it wouldn't let me change the username to domain\username. And the old username couldn't be entered either.

So the solution was to enter the new domain in the Preferences.

For future reference, here's the procedure:

  • Quit Microsoft Document Connection.app if it's running.
  • Go to a Finder window, pull down the Go menu, then "Go to folder" and paste in

    ~/Library/Application Support/Microsoft/Office/14.0/Document Connection/

  • Edit the file Document Connection.xml with your favorite reliable text editor.

  • Find the line containing authkey, there should be only one. The line should look like this:

    <attribute name="authkey" type="string">myusername</attribute>

  • Add NEWDOMAIN\\ right before myusername (make sure to use TWO backslashes, otherwise it just escapes the first letter in your username.

    <attribute name="authkey" type="string">NEWDOMAIN\\myusername</attribute>

  • Save, close, and reopen Microsoft Document Connection. You should see your NEWDOMAIN\myusername (but still gray'ed out) when you add or select an existing Sharepoint site. Enter your new password and optionally save to keychain.

Now you should be cookin' with gas!

share|improve this answer
    
Very cool, this actually works! –  nwinkler Jan 31 at 7:13

Strangely enough, this issue fixed itself after a while. One reason might have been that I had to recreate the login keychain at one point, having to enter all passwords again when I accessed the network share for the first time again. After that, it has been working without issues.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.