Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have an annoying new behavior on my MBP 13" running Lion (10.7.4) that I don't know what I did to provoke. I am familiar with so-called visual bells in terminals, but I've noticed a similar effect happening in any window in my OS X session - not just in Terminal. I've researched this and there appears to be a setting in System Preferences -> Universal Access -> Hearing where you can enable a screen flash in place of an alert sound. However, this is unchecked on my system.

Any ideas how I can correct this? I'm going to seize out soon if I can't figure out how to disable it...ugh.

EDIT: In response to the comments/questions below, I have confirmed that the plist also shows this setting disabled. I'm not sure what the advantage to removing the plist file and logging out/in would be.

plutil -convert xml1 -o - ~/Library/Preferences/|grep -A1 flashScreen 
<key>flashScreen</key> <false/> 
share|improve this question
Does it appear like the flash shown by the test screen flash button? – user495470 Aug 16 '12 at 23:23
Yes it does look the same. – AJ. Aug 16 '12 at 23:31
Have you tried something like deleting ~/Library/Preferences/ and logging out and back in? – user495470 Aug 17 '12 at 10:47
plutil -convert xml1 -o - ~/Library/Preferences/|grep -A1 flashScreen <key>flashScreen</key> <false/> – AJ. Aug 17 '12 at 17:26
The only harm that can come from removing this particular plist is that you'll need to reconfigure any UniversalAccess settings that you actually want. The benefit to removing it is that it will rule out strange configuration issues. – ephsmith Aug 19 '12 at 0:26

Do you have your system sound muted or volume turned all the way down? Even for the non-hearing-impaired the Mac will use visual bells (at least some of the time) when sound output is turned off.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.