Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I was trying to follow the instructions given on the page

After running the final command when I reopen the iTerm i find that only the background has changed to black and the text to cream color, it doesn't apply variable colors like blue to folders, some red colors for other file types. Please tell me how can I do so. Is there any other thing I can do to have a beautiful programmer's terminal.

share|improve this question
Are you still using iTerm v1? For displaying the output of ls with colors, you need to specify the -G argument (or alias it). – Gerry Aug 16 '12 at 11:52
What is the way other programmers do it? – Apurv Aug 16 '12 at 12:41
up vote 2 down vote accepted

I recommend Solarized if you're looking for a fully-realized lower contrast pastel(-ish) colour scheme. Setting files for iTerm are included in the package.

Solarized Screenshot

share|improve this answer

You can easily customize the color scheme from iTerm's preference. You can manually pick each of the 8 ANSI colors, or choose or import a custom color scheme.

Defining the colors does not automatically colorize all output though. For example to display the output of ls with colors you need to add the -G argument: ls -G.

You can also alias this to always display colorized output, by for example putting the following in ~/.bash_profile

alias ls="ls -G"
share|improve this answer
can you give some links to cool color schemes, instructions to import them. – Apurv Aug 16 '12 at 12:44

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.