Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I have set up iChat with different accounts: Facebook Jabber, Google Jabber, iCloud and an AIM account coming from MobileMe.

My AIM account regularly stops working where Messages will indefinitely get stuck at "Connecting...". I only experience this with my AIM account, the other accounts work fine. I also only started experiencing these problems since Mountain Lion.

AIM account gets stuck in Connecting...

Toggling the account back and forth to offline or quitting and relaunching Messages does not solve the problem, I need to completely remove the AIM account and reconfigure it.

Is there any way to solve my problem?

share|improve this question
    
I think that would could generalize the question: the same happens with other account types and Messages.app does not reconnect. Maybe someone knows a way to fix it. –  sorin Jan 31 '13 at 12:24
    
Personally, I only experience this with my MobileMe AIM account, and I have several Jabber accounts configured as well. –  Gerry Jan 31 '13 at 12:46

5 Answers 5

up vote 0 down vote accepted

I've been using AIM since the "AOL days" and I can say without a doubt that the AIM servers have always been unreliable. More so once we started using it via iChat and iChatAV and now Messages.

There are two (maybe more) reasons that I know of for AIM dropping out:

  1. The part of their service that checks your login credentials (username and password) goes down.

  2. The part of their service that allows clients other than the AOL web client to connect goes down.

I've never been able to figure out where the problem is and at this point there are so many other more reliable ways to connect via Messages that I'm not all that worried about it.

That said, many of my oldest buddies remain on AIM because that was the first system that Apple used with iChat, then iChatAV so it's important to keep that connection alive until we can all migrate to .me or google or something else that Messages supports and is more reliable.

share|improve this answer
    
I never really had significant problems with AIM before, but this also doesn't really explain why deleting and recreating the account immediately solves the problem? –  Gerry Aug 16 '12 at 11:50
    
Try using AIM with a different client or directly on the AOL site to see if the problem is upstream of Messages. I'm amazed you've never had significant or less than significant problems with AIM before, I've never met anyone who's used it for any significant amount of time who hasn't. It's a legacy service for sure and AOL isn't on the bleeding edge of these kinds of things which supports the idea that these problems, if they in fact are AOL's will not be solved any time soon. –  Richard Aug 16 '12 at 13:15

I have found that if you set the server to "login.oscar.aol.com:5190" and uncheck “Use SSL” that it works.

share|improve this answer

Delete your AIM account from Messages app, then re-add it.

share|improve this answer
    
Thank you, but I already came up with that solution in my original question :) –  Gerry Dec 1 '12 at 7:33
    
I had the same problem... and this actually worked for me. –  Camden S. Jan 7 at 16:05

I have this same question.

1) I have read that the SSL AIM server is less reliable that the non-SSL, so i can help to disable SSL.

2) I found an increase in reliability if I changed the default AIM server in Messages/iChat from "api.oscar.aol.com:443" to "login.oscar.aol.com:5190".

I have an Adium account set up which seems to be able to stay connected to AIM, using the same settings and the same server. But Messages/iChat drops the connection every few minutes and often won't reconnect when I ask it to. Eventually it always fixes itself and I can reconnect. But it doesn't seem to reconnect on it's own. This seems to be a bug in Messages/iChat.

If anyone has any hacks/tweaks/workarounds to make Messages in Mountain Lion OSX more reliable please share.

Someone should combine this answer with the more relevant parts of Richard's answer.

share|improve this answer

I too have the same problem? MY fix? I use message with MSN, FB chat, Gtalk. I have installed Adium for AIM alone.

share|improve this answer
1  
I removed the portion of your answer that was asking a different question. If you want to ask a question, feel free to ask it using the Ask Question button at the top right. –  Daniel Lawson Sep 10 '12 at 14:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.