Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Is it possible to disable the startup sound on an iMac G5, or at least decrease its volume?

The obvious way to do this would be to put a script in the shutdown folder (OS X 10.4.11) that mutes the sound, then put one in the startup folder that reverses it. Unfortunately, I've been unable to find a "mute" script.

Edit: To clarify, how can you set the system to mute with a script?

share|improve this question
    
Interestingly, this question said that it wasn't possible. –  Dori Jan 8 '11 at 1:33

3 Answers 3

up vote 2 down vote accepted

There is a 3rd party StartupSound.PrefPane for this.

share|improve this answer
    
I'm accepting this as the answer because it addressed my need, rather than what I explicitly asked. Both answers here - this one and Philip's - are good and to the point. –  Neil Fein Jan 8 '11 at 19:48

UPDATE: You're right. I am wrong. All you need is a script, and this is all you need to do:

set volume 0 
-- 0 = mute, 7 = full volume
share|improve this answer
    
A Firewire audio interface plugged in on startup will route the startup sound to the external device. I'm not sure if this works with USB audio. –  Neil Fein Jan 7 '11 at 17:25
    
...also, I'm not certain this is correct. Aside from the scenario in my above comment, muting the startup noise before shutting down will make the startup noise go away when restarting, no hardware required. I think my question should have been, How can you set the system to mute with a script? –  Neil Fein Jan 7 '11 at 17:27

If you want to disable it temporarily (as the title suggests) it´s easiest to hold down the "mute" key (on the upper right of your keyboard) during the initial seconds of booting.

share|improve this answer
    
Unfortunately, this doesn't work on my Mac. Would downvote, but I don't have the rep yet. (If this works on some Macs and not others, you might consider going into more detail; this would be an extremely handy piece of info for users of the Macs it does work on.) –  Neil Fein Jan 25 '11 at 19:49
    
No need to down-vote, as this has worked on every Mac since at least Mac OS X - if it does not work on your Mac, would you be so kind and comment on what kind of Keyboard you use (Apple, other Vendor, wired, wireless,…) and also whether turning down the volume completely before rebooting stops your Mac from playing the chime? If the latter is not the case, please try resetting your parameter RAM, as described here: support.apple.com/kb/HT1379?viewlocale=en_US –  Asmus Jan 26 '11 at 16:58

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.