Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I am using WinOS at the office and MacOS at home. But I am more experienced on WinOS. While i am browsing (via firefox), I use cmd+q accidently to write "@" mark because of WinOS and keyboard habbits. So, the browser quits and i lose all what I've written.

Is there a way to constrain this key combination on MacOS or do I have to look for it on Firefox? (I know, the best way is adapting MacOS but mostly I am working on WinOS.)

share|improve this question
add comment

3 Answers

up vote 5 down vote accepted

Unfortunately, Firefox (at least the 3.6 version I experimented with) does not disable the command shortcut for Quit when you change it in System Preferences.

I think the quick and easy fix for this is to add ⌘Q as a global shortcut to something else innocuous. In my experiments, I found this to work:

  1. Open System Preferences.
  2. Click on the Keyboard pane.
  3. Click Keyboard Shortcuts tab.
  4. Click Exposé & Spaces shortcuts in the left side list.
  5. Under "Exposé" change the shortcut for "Desktop" to ⌘Q

Now when you accidentally hit ⌘Q, your desktop will magically and amusingly appear reminding you of your folly. Hit ⌘Q again and you're back exactly where you were.

As a sidenote, after a while you may want to change this back after you "unlearn" your behaviour. ⌘Q, the Mac equivalent to "ALT-F4" has been the standard shortcut since the introduction of the Macintosh, and like the other "standard" shortcuts ⌘W,⌘Z,⌘C,⌘V and so on, it's best to learn them to ease use of other Mac computers or when you upgrade.

share|improve this answer
    
Good idea. I'd suggest something a little more innocuous than Exposé if you're not going to break the habit, though. Spotlight, maybe (hit Esc to dismiss). Less likely to interrupt your workflow as much. –  Matthew Frederick Jan 11 '11 at 2:30
    
@Matthew Well, what I like about Exposé idea is it's immediately apparent you hit the wrong key and it's a toggle so you can just hit it again to get back to the right state. Spotlight works in the same way so that's another option. –  ghoppe Jan 11 '11 at 15:20
    
Good point, you'll definitely know it when it happens with Expose. There's little chance you'll go on blindly typing into the wrong box. –  Matthew Frederick Jan 11 '11 at 23:21
    
this is a good solution for bad habits. Thank you. –  ARTniyet Jan 12 '11 at 23:02
add comment

Here's how to change that particular shortcut for Firefox:

  1. Open System Preferences. This is in the Applications folder.
  2. Go to the Keyboard pane, and click the Keyboard Shortcuts tab.
  3. Click the [+] button near the bottom.
  4. Select Firefox from the Application menu. For Menu Title, type 'Quit Firefox' (without the quotes)
  5. For the Keyboard Shortcut, push a key combination that you're not likely to hit by accident (control-q, for example).
  6. Open Firefox. Now, cmd-q does nothing (you can quit with ctrl-q, or whatever you set it to).

Hope this helps.

share|improve this answer
    
Thanks for the answer but this only adds another Quit shortcut to Firefox. cmd+q still quits Firefox –  ARTniyet Jan 7 '11 at 23:24
    
If that is the case, what you typed didn't match the name of the command exactly. Try again, making sure that what you type in to System Preferences matches exactly the name of the command you see in the program (no quotes or anything). –  Nathan Greenstein Jan 8 '11 at 0:20
    
I can confirm that Firefox (3.6) does not remove the cmd-q shortcut, the System Preference shortcut is added, but the default is not removed. –  ghoppe Jan 10 '11 at 19:19
    
Granted, this is non-standard behaviour, as most other applications will indeed disable the standard shortcut. –  ghoppe Jan 10 '11 at 19:42
    
This doesn't work for me either. –  Neil Fein Jan 10 '11 at 23:29
add comment

I've got the same problem as him Nathan, even though it shows the changes take effect (Quit Firefox as ^Q) when I click on the Firefox menu, cmd+q still closes the application. I'm not too sure why though since this method works for Google Chrome.

share|improve this answer
    
Works perfectly OMM. Not sure why it's not happening for you. Can you send a screen cap of those two menus? –  Nathan Greenstein Jan 9 '11 at 15:41
2  
I realize you probably posted this because you don't have enough reputation, but in the future this sort of response to someone else's question is best left as a comment. –  ghoppe Jan 10 '11 at 20:08
    
@NathanGreenstein: You must be the only person in the world for whom that's true. There are numerous reports here and elsewhere on the Web (Firefox bugs) that Cmd+Q is still activated, and adding a "keyboard shortcut" just enables both! –  Noldorin Sep 3 '12 at 14:53
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.