Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

When I activate Mission Control and try to drag drag, say, two windows to another desktop, the first drag works fine. I can drag the window to the other desktop's thumbnail, which darkens, and then release the mouse, and the window moves to that desktop just as it should.

When I try to drag the second window, however, the recipient space won't darken—it doesn't register that I'm dragging the window over it—and when I release the mouse button, the window will snap back to its original position as though I'd dragged it to some other part of the screen.

When I initiate another drag on the second window (the third drag total) it'll work properly. Then, I'll drag another window and it won't work. It occurs every other time I drag a window, with perfect regularity, as far as I can tell.

Other points:

  • Non-working drags doesn't have to be over a space for the next drag to work. I could drag a window an inch, release it, and then pick it up and drag it to another desktop just fine.
  • The "new desktop" button never seems to suffer from this problem.
  • The problem also occurs on the guest account.

Any ideas how to fix it, or why it's happening? Any help is appreciated.

share|improve this question
    
I can also reproduce it on 10.8. I guess the most likely way to get it fixed is to file a bug report at bugreport.apple.com. –  Lri Aug 13 '12 at 18:59
    
It's not fixed in 10.8.1. –  Toph Aug 23 '12 at 16:08

2 Answers 2

If you'd like, there is a keyboard shortcut which allows moving windows between desktops. All you need to do is to to go to System Preferences -> Keyboard -> Keyboard Shortcuts -> Mission Control and enable Switch to Desktop 1, 2 ,... n Desktops you have.

Then in order to move the window you need to move your mouse to start dragging the window and then use Switch to Desktop keyboard shortcut.

share|improve this answer

This post does not cite any references or sources. Please help improve this post by adding citations to reliable sources. Unsourced material may be challenged and removed.

This has been killing me, too. But I went into the MC preferences pane and unchecked "Group windows by application." It worked.

share|improve this answer
    
You're right—this does fix the issue. Though I do prefer the grouped look, I guess it's back to this Leopard-ish mode for now. –  Toph Aug 23 '12 at 16:09

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.