Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

When I installed RVM, it turns out that it created .bash_login with this:

[[ -s "$HOME/.rvm/scripts/rvm" ]] && source "$HOME/.rvm/scripts/rvm" # Load RVM into a shell session as a function

And I now have to manually source .profile, where my BASH configs are. How do I get .profile to automatically execute?

share|improve this question

1 Answer 1

  1. Delete ~/.bash_login
  2. Move [[ -s "$HOME/.rvm/scripts/rvm" ]] && source "$HOME/.rvm/scripts/rvm" # Load RVM into a shell session as a function into the bottom of your ~/.profile.
  3. Success!
share|improve this answer
    
Thanks! And shell session - what's the format for that? –  lolajl Aug 13 '12 at 1:46
1  
Everything after the # is a comment, there is no specific format –  patrix Aug 13 '12 at 3:56
    
Okay, so I just copy that line and paste into the bottom of the .profile file? Sorry, I don't have experience setting up a function so I'm not sure how to do that. –  lolajl Aug 13 '12 at 11:10
    
That's correct. Just move the contents of ~/.bash_login as-is into ~/.profile, preferably at the bottom. Delete ~/.bash_login. Done –  Jason Salaz Aug 13 '12 at 19:32

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.