Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Since updating to Mountain Lion I lose my internet connection every time that my 24 inch Mid 2007 awakens from sleep. It doesn't occur when going to sleep or during but only on activating it again. 100% of the time. Any ideas?

share|improve this question
1  
Please add what model of iMac this is. Have a look at the "System Information" app. Should be something like iMac7,2 –  Max Ried Aug 12 '12 at 19:02
    
It's a 24 inch Mid 2007 with 2.4 GHz Intel Core 2 Duo. The internet connection is WiFi. –  takeenan Aug 12 '12 at 19:18
1  
From what I can see on the coverage for Mountain Lion 10.8.1 (there was a beta update seeded to developers, according to Engadget and others), there is a known issue with wi-fi which is being addressed by this update. –  user479 Aug 12 '12 at 23:20
    
FWIW my Mac Pro as well has the same issue for wired network connections... –  user27639 Aug 18 '12 at 13:58

2 Answers 2

I called Apple Tech Support yesterday. My connection drops after waking from sleep, and it is a hardwired connection (not wifi). They told me it is a known problem with iMacs, and while it eventually will be fixed in a software update, the only thing to do now is to disable the machine sleep on the energy saver panel, which I did..

share|improve this answer

I had this problem too. I solved it by going to my router's configuration settings and changing some settings under the WiFi setting (it worked for me).

First of all make sure you’re using WPA2; for WPA-type use passphrase and choose your password. But make sure there are no numbers in your network password.

Second change your channel. Before I had set it on channel 6 now I changed it on channel 11.

Also make sure your encryption is set to AES.

I'm giving you also a picture of my WiFi settings down below. settings

share|improve this answer
3  
"But make sure there are no numbers in your network password" - without evidence to the contrary, that's ridiculous. –  Dan J Oct 23 '12 at 16:22
    
Just try and you shall see! ;) posted this olso on another forums and for 90% of them it helped! is that also ridiculous...? –  Gio Twomind Oct 24 '12 at 4:54
    
I assume that changing the channel contributed more to the solution than using a password not containing any digits. –  patrix Oct 25 '12 at 4:28

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.