Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I downloaded and ran the Mountain Lion Installer today for my mid-2007 iMac. After rebooting and preparing to install, I receive an error message that the hard disk was damaged and the installer could not run.

I can't boot to the partition and am working from the install partition instead. Disk Utility cannot repair the partition, and detects no problems with parent volume. Time Machine cannot restore to the partition as it is apparently locked or unavailable (it is greyed out in the program).

I've booted in Single User mode and run /sbin/fsck -fy and /sbin/mount -uw /, but this does not allow me to run fsck on the problem volume - just the install partition it appears.

This is the partition info from diskutil info /dev/disk0s2:

Device Identifier:        disk0s2
   Device Node:              /dev/disk0s2
   Part of Whole:            disk0
   Device / Media Name:      WD Black Caviar

   Volume Name:              WD Black Caviar
   Escaped with Unicode:     WD%FF%FE%20%00Black%FF%FE%20%00Caviar

   Mounted:                  Yes
   Mount Point:              /Volumes/WD Black Caviar
   Escaped with Unicode:     /Volumes/WD%FF%FE%20%00Black%FF%FE%20%00Caviar

   File System Personality:  HFS+
   Type (Bundle):            hfs
   Name (User Visible):      Mac OS Extended
   Owners:                   Enabled

   Partition Type:           Apple_HFS
   OS Can Be Installed:      No
   Media Type:               Generic
   Protocol:                 SATA
   SMART Status:             Verified
   Volume UUID:              8880D8D2-AEC8-3466-81D3-4ABBE296733A

   Total Size:               1.3 TB (1278311751680 Bytes) (exactly 2496702640 512-Byte-Blocks)
   Volume Free Space:        817.2 GB (817164238848 Bytes) (exactly 1596023904 512-Byte-Blocks)
   Device Block Size:        512 Bytes

   Read-Only Media:          No
   Read-Only Volume:         Yes
   Ejectable:                No

   Whole:                    No
   Internal:                 Yes
   Solid State:              No

`

How can I regain write access to the partition to diagnose it?

Thanks.

share|improve this question
add comment

2 Answers 2

up vote 2 down vote accepted

To fix this I re-partitioned the volume from Disk Utility running off a USB boot volume. This got the volume accessible and responsive again. Then I restored from an earlier Time Machine backup, and proceeded to re-download and run the Mountain Lion installer, this time with no problems.

While it may be faulty hardware somewhere, I can't rule out that a bug or some other interference for the Mountain Lion installer damaged the partition. It has been working fine for days now, and was working fine prior to ML.

share|improve this answer
add comment

Please "burn" ML to USB or DVD and boot by it. Then use Disk Utility to repair the disk (or partition). It may be a cable HDD problem, or the HDD is bad.

share|improve this answer
    
Thanks. I copied InstallESD.dmg to a USB drive and ran Disk Utility from there. It cannot repair the partition, and recommends I reformat it. What exactly is a cable HDD problem? The cable connecting the HDD to the controller may be bad? –  walker Aug 11 '12 at 15:44
    
If Disk Utilities can't help you in this problem, please go to Genuine Apple. Replace cable/hdd (or both). –  tquang Aug 12 '12 at 15:00
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.