Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

In Lion I enabled the "Top sekret" debug menu and checked the box to show 14 days in the weekview. In Lion it worked quite nice.

Now I upgraded to Mountain Lion it doesn't work as nice as it was and I want to change it back to the normal 7 days in a week-view. One problem, I can't enable the debug menu anymore! So I don't know how to change it back.

I already searched the internet, looked in the App bundle etc, but I can't find where Calendar stores this setting. Do you know how to "reset" Mountain Lions calendar to the default setting for the weekview?


Just replaced my Calendar.app with the Calendar.app from another Mac, but no luck. So it seems that this preference is saved somewhere else. Hope somebody can point me in the correct direction.

share|improve this question

3 Answers 3

up vote 2 down vote accepted

Like you, I had set iCal's week view to 14 days using the Debug menu in iCal under Lion before upgrading to Mountain Lion. However, at least for me, changing the value via Calendar>Preferences... did not permanently change the setting. When I restarted Calendar, it always reverted to the previous value (in my case, 14 days) if the value was not one of those available from the menu (i.e., 5 or 7).

There is another way to set the number of days shown in week view, and that's to use the following shell command:

defaults write com.apple.iCal CalUIDebugDefaultDaysInWeekView 7

This works where Calendar>Preferences... does not, for reasons I don't understand.

The "7" in the command above can be another number, including ones not previously available from Lion iCal's Debug menu, e.g., 10. However, I find that Mountain Lion's Calendar has a peculiar bug when the value is not 5 or 7: in week view, if you have moved the viewed range of dates such that today is not visible, then using View>Go To Today (or Command+T) does not move the days in the grid to show today. The title changes to the correct dates, but the days in the grid don't change to the correct range of dates.

(Hat tip to this posting for pointing out that the numerical value could be anything, not just a value shown in iCal's Debug menu.)

share|improve this answer

Another (and more definite way) to get this fixed:

  • Close the Calendar app.

  • Edit ~/Library/Preferences/com.apple.iCal.plist and REMOVE the following keys:

    • CalUIDebugUseIPadStyleEventLayout
    • last calendar view description
    • IncludeDebugMenu
    • CalUIDebugDefaultDaysInWeekView
  • Save and restart Calendar.

You may need XCode or the PList Editor to edit the file (or use plutil to convert to text, edit with TextEdit and convert it back to binary).

share|improve this answer

Finally I figured it out! :) Was pretty simple actually. Just go to Calendar > Preferences... and change the value of days in a week to another value. This will make Calendar reset the number of days in a week!

Full story over here.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.