Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Finally my company bought me a MacBook Pro Retina (yeah! I feel so lucky!)

I always used Windows (and need it, because of Visual Studio), so I installed VMware Fusion.

I installed Windows 7 as virtual machine. The problem is that whenever I launch the machine, VMWare automatically sets the resolution of the guest to the maximum available on the mac (that is 2880x1800). So I changed the resolution from Windows and set it to 1440x900, but when I restart, on the logon screen, it reverts back to 2880x1800 (automatically!). I thought it was due to the VMware Tools, so I uninstalled them. It now works correctly, however I lose a lot of features without the Tools installed. How can I solve this?

share|improve this question
I have the same problem but am using the latest version of VMWare, 5.0.2 – ajcw Dec 21 '12 at 18:55
up vote 3 down vote accepted

Download the VMWare Fusion 2012 technology preview, this issue is fixed in that release.

share|improve this answer
I just purchased a 15" Retina MacBook Pro and had the exact same issue as you did. I'll assume that you are running VMWare 4 and the best solution I found was to upgrade to VMWare Fusion 5. This new version has explicit support for the immense resolution of the Retina screen and it solved all of the resolution related problems I had. – Paul Shaw Nov 19 '12 at 20:54

I'm using VMWare Fusion 5.0.3. With vmwaretools installed, it's very easy to change the resolution on the Windows VM:

  • go to Virtual Machine > Settings > Display
  • there is a checkbox Use full resolution for Retina display
  • uncheck it and the vm changes back to normal resolution.
share|improve this answer
Good call, this did the trick! Thanks. – carl_h Oct 20 '14 at 9:38
Thanks! I created an account here just to give you a +1. That was right on spot! – eestein Jul 30 '15 at 16:54
I am using El Captain, Windows 7 pro inside VMware fusion. Now I can set resolution and don't allow it auto-changing. – Do Nhu Vy Jul 22 at 21:43

Edit ~/Library/Preferences/VMware Fusion/preferences file by adding following lines:

pref.autoFitGuestToWindow = "FALSE"
pref.autoFitFullScreen = "stretchGuestToHost"

pref.autoFitGuestToWindow = "FALSE" disables auto fit for Single Window mode. pref.autoFitFullScreen = "stretchGuestToHost" disables auto fit for Full Screen mode.

share|improve this answer
This seems like the best answer. Worked perfectly. (Of course, make sure to restart VMWare Fusion after making these changes). – caleb Dec 26 '14 at 19:40

You can also use the following command to set the resolution:

C:\Program Files\VMware Tools\VMwareResolutionSet.exe"  0 1 , 0 0 1920 1440
share|improve this answer
Turn on Retina option go the VM, set the resolution you like delete this resolution set exe file mentioned above this will stop reverting back – Bishoy Hanna May 31 at 3:25

I dont have a real fix I guess that will require a patch from VMware. In the meantime I found this hint via Google:

Go out of full screen mode (ctrl-cmd-F) and then back again.

share|improve this answer
Thank you, it works! – Umar Jamil Aug 13 '12 at 16:27

I am using VMWare Fusion 5.x on MAcBook Retina 13' and as a workaround, I have created a .bat file (auto executable) to automate the commands as suggested by Michiel on my Windows and I just double-click it to bring back my preferred resolution.

ResetResultion.bat file has the following content:

"C:\Program Files\VMware\VMware Tools\VMwareResolutionSet.exe"  0 1 , 0 0 1920 1200
share|improve this answer

protected by Community Jan 11 '15 at 21:57

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.