Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a single message in Mail on my iPhone 4 that just cannot be deleted. I get a popup saying Unable to move message - The message could not be moved to the trash folder.

I'm using the latest version of iOS. The account is an Exchange Active Sync account and deleting other messages is not a problem. I also use the same Exchange account from Outlook on my desktop and the message in question does not exist in Outlook. It only shows in Mail on iPhone.

I also have an another IMAP account on my iPhone and deleting isn't a problem on that account.

How can I remove this rogue message?

share|improve this question

You could try removing the Exchange account completely and setting it up again. Maybe this also deletes the message.

share|improve this answer

It sounds like Mail got a bit out of sync and it can't move the message because it doesn't exist. Here are a few things you can do to get it to resync.

  1. 'Quit' the Mail app - from the home screen, double 'click' the home button to show the list of recent apps. Press and hold the Mail app icon until it shakes and displays a red icon. Tap the red icon.

  2. Restart your phone - always a good thing to try with software and caching problems.

  3. Re-configure your mail account - this is a bit of a pain, but you should won't lose any messages because they are all on the server.

share|improve this answer
Thanks. I tried them, but no luck :( – GiddyUpHorsey Mar 5 '11 at 14:21
up vote 2 down vote accepted

I found that after a month the undeletable email would disappear from the mail app. This I can live with because I don't like the other option of setting up the Exchange account all over again.

share|improve this answer

I had the same problem occur recently with iPhone 5. After several days of trying everything under the sun I deleted the account and set it up from scratch. Not really a solution cause I'll be upset if I have to do this frequently.

share|improve this answer

I found a quick way that worked.

  • Go to the mail setting
  • Unselect mail (checkbox) leave the others as they were.

This takes a minute or so and the corrupt e-mail go. Then reselect mail and the correct ones appear.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.