Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I have a few Exchange accounts set up in Mail that are working fine. Deleting sends the mail to the Trash folder, archiving sends the mail to the Archive folder. However, one of the accounts won't let me archive. The mailbox has a folder under the "Archive" section on the sidebar, and I can manually drag messages to it, but when I click Archive I get the following:

The message “[subject]” could not be moved to the mailbox “(null)”

The destination mailbox does not exist.

I would assume this means that Mail can't find the appropriate folder to put the message in, but since the account has a folder under the Archive heading, I'm confused.

Any ideas?

share|improve this question
    
Had the same problem on Mac OS X Mavericks 10.9.1 –  khrf Jan 10 at 19:03

1 Answer 1

up vote 4 down vote accepted

I had the same problem. I went into Preferences > Accounts and deselected "Enable this account." Then, I quit Mail and restarted it. I went back into Preferences > Accounts and selected "Enable this account" and it all started working.

share|improve this answer
    
Fantastic! This works. Thanks. –  Matthew Sep 21 '12 at 20:56
    
Thank you very much! It helped me with the same problem! –  khrf Jan 10 at 19:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.