Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

In Mountain Lion, when I drag a file to the desktop, it's automatically moved to a neat grid in the upper left of the desktop.

But I want it to stay in the spot to which I dragged it (usually because it's one I can see, so I can drag it to another window).

I thought it might be the "sort by" setting, but it's set to "none", so that's not it.

Thanks to those suggesting I change "sort by", but it's already on "none". Here's what's weirder: the files sometimes snap to a neat grid, and sometimes appear near (but not exactly where) I dragged them, with no other changes (I literally tested a few in row from the same program). It's really bizarre since in the answer below, i cannot reproduct this and I'm trying to confirm (for others) that it was fixed by an OS update. The issue may be related to external displays being attached on systems running 10.8.2 and earlier.

share|improve this question
    
Then there is something off or you are overlooking something. Are you sure you are looking at the View options of the Desktop? –  Gerry Aug 7 '12 at 15:11
    
When you wrote "I drag a file to the desktop", I assumed it was a move within the file system. Would it be possible that the issues you describe only arise when dragging from a program? Which one? –  myhd Aug 14 '12 at 15:09
    
is this really the answer? that all files moved to desktop first go to one inconvenient corner? in 10.7. I used preview very much to divide pdf-files into separate documents just by dragging one or more pages to the desktop - now they all snap to one free space on the desktop - although preferences say "sort by: none".... Did you find a more satisfying answer than "it will always snap to the grid"? –  user28559 Sep 4 '12 at 19:36
2  
I have a similar problem, but only when an external display is connected (so I am using 2 differently size displays). If I drag an image from Safari to my desktop, it ends up about 1000 pixels below where I dropped it (often behind another window). Since this only occurs with an external display attached, I suspect the displacement is related to the arrangement of them. –  dmnd Dec 14 '12 at 19:16
    
Right-click Desktop and select "Snap to Grid". The option in the context menu will now have a check next to it but at least will release your desktop. This was hellish! –  Robino Jun 4 '13 at 12:43

4 Answers 4

In Finder: cmd+J ➝ Sort by: none.

share|improve this answer
1  
The actual window of the desktop has to be selected; the ~/Desktop/ folder has separate view options. –  ؘؘؘؘ Aug 7 '12 at 16:43
    
I assumed the Desktop (not: the folder named "Desktop") was visible somewhere on your screen. Just to make sure, click once on the Desktop background to activate the Finder and deselect any other folders or files, then press the cmd+j keyboard combination. This should do it! –  myhd Aug 7 '12 at 16:56
    
I tried this, it's already set on "none" –  Jaydles Aug 14 '12 at 15:03
  1. Right Click on your desktop.
  2. Select “Show View Options.”
  3. In the “Sort by:” drop down, select “None.”
  4. You can now place icons wherever you want.
share|improve this answer
    
I tried this - it's already set on "none". –  Jaydles Aug 7 '12 at 18:25
1  
If you add a new file to the Desktop, it will always snap to the grid. You can move it around after that. –  duci9y Aug 8 '12 at 8:40

This has simply stopped happening. I think it must have been fixed in an OS update as I still regularly have an external monitor connected and no other change was made to my system.

Please upvote this only if you had this problem and it stopped since you updated. I don't want to accept this if others who updated are still having the problem and need help.

share|improve this answer
    
If you can confirm the exact levels involved, it will help once newer updates arrive and remove doubt for people experiencing the issue as to what updates cleared the issue. –  bmike Dec 14 '12 at 19:31

Testing with 10.8.5...

This appears to be a multi-screen issue. I noticed the same thing, same settings as others. If I drag and drop an icon with an external monitor attached it defaults to the top right. If i disconnect the monitor and try the same thing it stays in place exactly where I put the icon.

Can anyone else confirm it? Someone should probably file a bug report, it doesn't look like it was intentional since it's only happening with multiple monitors.

share|improve this answer

protected by Community Sep 20 '12 at 22:57

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.