Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

One of the new features of Mountain Lion is the Messages app - and the "fact" that all your Messages threads are consistent across all your devices.

I would really like to have my the threads that I have going on my phone, automatically sync to my iPad and ML Mac. I understand SMS messages will not sync. The one caveat that I noticed is that it must be started on my Mac.

How do I get iMessages in sync across an iOS 5 (or older) iPhone, iPad and Mac?

share|improve this question
    
One other note, the messaging is to phone numbers (albeit still iMessage). I can message to a phone number from my Mac or iPad, but maybe I need to switch to email addresses? –  bassplayer7 Aug 7 '12 at 14:07
    
For those syncing devices with iOS 6, things have changed somewhat since this question. There is a similar question here that should work as an updated guide. –  bassplayer7 Jan 8 '13 at 14:34
    
Apple should let you store all messages in one spot (iCloud) instead of having each device store the messages it's received. –  MattDiPasquale 21 hours ago

1 Answer 1

up vote 6 down vote accepted

Theres been a few reports online of messages sync being a bit buggy if you don't set it up exactly right. Heres a few solutions that should get everything syncing nicely for you:

Firstly, you need to have all devices set up to the same Apple ID

iOS Devices (iPhone, iPod Touch, iPad):

  1. Navigate to Settings > Messages.
  2. Make sure iMessage is turned on.
  3. Tap on Receive At.
  4. Check your Apple ID. Make note of this Apple ID.
  5. Tap on Caller ID.
  6. Use your email address. If you use your phone number (assuming you’re on an iPhone), then the non phone devices (including the Mac) may not (and probably won’t) see the messages.

Mac version:

  1. Navigate to the Messages app.
  2. Go to Preferences > Accounts.
  3. Add the same Apple ID as you used on the iOS devices.

 

In a nutshell: everything needs to be consistent. Use the same Apple ID everywhere and an email address as a caller id for best results.

If things are still not syncing, try the following.

  1. Delete all your previous conversations: Some people have reported that they had to delete all of their conversations before things would sync up.
  2. Make sure you have your phone number added to your Apple ID account online.
share|improve this answer
    
SO cool - thanks for the great answer!!! I did find that I was using my phone number on my iPhone as the caller ID. All the other settings appear to be correct. I've done some testing this A.M. and the sync seems to be working! It doesn't sync previous messages (understood), but appears to be syncing current ones extremely well! –  bassplayer7 Aug 8 '12 at 13:31
    
I have an iPhone 4 and the Caller ID option isn't there for me to adjust... I have updated my iPhone to iOS 6 so I'm not sure what else to do. –  user33298 Oct 22 '12 at 14:32
    
@Jul, It's actually called "Send & Receive" (at least in iOS 6). To get there, navigate to Settings > Messages > Send & Receive. –  bassplayer7 Oct 23 '12 at 15:38

protected by bmike Dec 2 '12 at 23:21

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.