Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I've updated to Oracle's 1.7 64-bit beta, and this is what my Java Preferences window looks like (you will note that the webapp checkbox is checked and I've restarted my machine since checking it):

Java preferences

I've tried unchecking SE 6 32-bit, 64-bit, and both, as well as disabling SE 7. Doesn't do anything. I've rebooted after installing. No dice. I've checked Software Update. Nope.

java -version reports:

java -version java version "1.7.0_05" Java(TM) SE Runtime Environment

(build 1.7.0_05-b06) Java HotSpot(TM) 64-Bit Server VM (build

23.1-b03, mixed mode)

This test page in Safari returns a blank, Chrome asks for Java plugin, and Firefox says "Java is broken":

http://www.java.com/en/download/testjava.jsp

which java says /usr/bin/java

Any idea what the problem is? This is endlessly frustrating given how mindlessly simple it is to install Java in both Windows and most Linux builds.

Have tried reverting to SE 6 by uninstalling SE 7. Here's the infuriating reality I am dealing with:

share|improve this question
    
As this is re a beta I think it is too localised –  Mark Apr 13 '13 at 21:04

2 Answers 2

For chrome: have you tried enabling javascript? it's in the contents setting bit of the preferences. In Safari, in the Preferences -> Security settings, there is a 'enable Java', 'enable JavaScript'. In Firefox Javascript is in Preferences -> Contents.

If JavaScript and Java are enabled then the problem is going to be a different one, but it pays to check.

share|improve this answer
    
Yes, Java and Javascript are both enabled on all my browsers. –  Kyle Aug 7 '12 at 15:35
3  
JavaScript has nothing to do with Java at all… –  Tyler Crompton Aug 15 '12 at 23:27

My solution was to purchase and install Mountain Lion. It works now. Really wish I knew what the actual problem was though...

share|improve this answer
1  
I have Mountain Lion and it works in Safari but not Chrome. I have the same setup as you in Java Preferences. –  Tyler Crompton Aug 15 '12 at 23:28

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.