Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I've a lot of softwares on my Mac, so, I've forgot to check some of them before upgrading MacOS to Mountain Lion (from Lion)

Since Mountain Lion, VirtualBox throw this message when I try to open it:

You can't open the application "VirtualBox.app" because it is not supported on the type of Mac

What is the better (not the simpler but really the better) way to update VirtualBox without breaking anything?

Can I install the latest version over the old one?
Or must I uninstall completely the old one and reinstall it form scratch?

Or anything else?

Which are the problems I can expect?

Thanks in advance for your help.


[EDIT] in reply to the comment:

The VirtualBox.app details declare version: 4.1.8

For the Mac, it's a

15 inch, Late 2011

Processor 2.4 GHz Intel Core i7
Memory 8 GB 1333 MHz DDR3
Graphics AMD Radeon HD 6770M 1024 MB
Software OS X 10.8 (12A269)

share|improve this question
    
What version of VirtualBox do you currently have? What type of Mac do you have? –  Gerry Aug 7 '12 at 7:32
    
@Gerry post edited with informations you need, thank you for your help –  Pascal Qyy Aug 7 '12 at 7:58
    
FWIW, VirtualBox 4.1.18 is the first version that specifically supports Mountain Lion. –  pmdj Aug 7 '12 at 8:31
1  
@pmjordan compatibility was earlier than 4.1.18. virtualbox.org/ticket/10267 notes that 4.1.16 was made compatible with a seeded build of Mountain Lion (and that Apple permitted that version to run). –  Graham Perrin Aug 10 '12 at 0:52
add comment

1 Answer 1

up vote 2 down vote accepted

There should be no problems upgrading to the latest version of VirtualBox. You can just download and run the installer to upgrade, no additional uninstall steps are required.

You can also update automatically from the "VirtualBox" menu, by choosing "Check for Updates...". It should find a newer version, and prompt to download and install.

share|improve this answer
    
It's impossible to update automatically from VirtualBox as it can't open… But I can install the new version over the old one? –  Pascal Qyy Aug 7 '12 at 8:42
    
@PascalQyy, you're right, but indeed you can just download the latest version and install it over the old one. –  Gerry Aug 7 '12 at 8:54
    
Thank you for your help –  Pascal Qyy Aug 7 '12 at 8:57
1  
In the past, following an update, a saved VirtualBoxVM was no longer usable. For that reason my habit is to have no VirtualBoxVM in the saved state before any update of VirtualBox. In an edge case I might suggest attention to Exceptions.plist virtualbox.org/ticket/10267#comment:5 but proceed with caution – risk of kernel panic. –  Graham Perrin Aug 10 '12 at 1:05
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.