Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

When I create new Keynote presentations on my Mac they are not showing up on my iOS devices. I noticed when I open a document from iCloud there is a dotted iCloud symbol in the file viewer.

Is there a way to manually force the sync to occur? Last time I resolved this by disabling my iCloud account and re-enabling it, this is pretty painful though as it takes awhile.

Anyone know why these documents won't sync?

enter image description here

share|improve this question
    
I have the same problem but deleting that file and rebooting hasn't worked for me. The sync works the other way - files generated on my iOS devices show fine on the Mac, but if I edit them (or create new ones) the files don't show on iOS. Any further suggestions? –  user44742 Mar 9 '13 at 22:26
    
Check connection and restart Keynotes? I've got this issue today and it has fixed in this way –  Eir Nym Mar 9 '13 at 22:29

2 Answers 2

In my case that file was not present, so i deleted:

~/Library/Preferences/com.apple.iWork09.plist

That did the trick.

share|improve this answer
up vote 5 down vote accepted

Ok so I got ahold of Apple support and they helped me resolve the issue by deleting the Keynote preferences file located at

~/Library/Preferences/com.apple.iWork.Keynote.plist

They instructed me to move it to the Desktop for backup purposes and then reboot the system, after rebooting and opening Keynote again the file was regenerated and the issue was resolved. They then had me trash the old property list file.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.