Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I'm using a calibrated version of my monitors color profile. The monitor is calibrated inside of the OS X System Preferences on a Mac Pro.

The standard color profile of my Samsung monitor "Syncmaster" is very yellow/dark and pretty much unusable.

When I boot up, the login screen looks horrible because OS X loads the unmodified color profile, when I type in my password to log in the color profile changes to my calibrated profile ("SyncMaster Calibrated").

How do I force OS X to always use my calibrated color profile?

share|improve this question
    
I tried changing the DeviceProfileURL keys in /Library/Preferences/.GlobalPreferences.plist, but it didn't seem to have any effect. I even tried copying another icc file over the factory profile, but it was replaced with the original profile after restarting. –  Lri Aug 6 '12 at 12:20

2 Answers 2

up vote 3 down vote accepted

I just solved it!

SOLUTION:

1. Activate the OS X Root User in the System Preferences.

How to activate the root user: http://support.apple.com/kb/ht1528

2. After the root user is activated, log out from your account and log in as the user "root".

Go to System Preferences -> Displays -> Color and pick the color profile (that you want on your OS X Login Screen).

Log out of the Root Account and you'll see the selected color profile will be used on the Login Screen.

3. Log back in to your normal account.

Now you can deactivate the root user via System Preferences, the same way it was activated.

The color profile selected via root user earlier will stay.

Result: The color doesn't change anymore between Login Screen and account and I don't have a yellow/dark login screen anymore, finally!

Could Apple make that easier? YES! But that's a pretty fast way to do it, without any "hacking" tricks.

share|improve this answer
    
Just tried this with Mavericks and it did not work :-( –  Mathew Sep 8 at 0:45

You need to copy the colorsync profile into the Computer library files as opposed to your own. Go to your hard drive => system => library =. ColorSync => Profiles and save your color profile in there.

Now open the ColorSync utility in your applications/utilities folder. Click the devices tab then click the dropdown next to displays and select your display from the menu. Assign the profile that you've just saved into your library files and your problem will be solved!

share|improve this answer
1  
My color profile IS in the system library folder but as soon as you go to the login screen, OS X loads the default color profile. I'm on Mountain Lion. –  JBX_6 Aug 6 '12 at 5:37
    
Sounds odd... The only reason I could think of for OSX to load a different color profile at the login screen is if the color profile is assigned to a user and not overall. So long as the right color profile is assigned to the device in ColorSync and that profile is contained in the system folder ie HD/system/library/colorsync/profiles and not the user folder then OSX should always load that profile for that device regardless of whether or not you're logged in. –  InfluenceJamie Aug 6 '12 at 5:46
    
This does indeed only make it available to all users (and is the same as checking "Make available for all users" when running the built-in calibration tool), but does not use the profile when logged out. –  Gerry Aug 6 '12 at 7:04

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.