Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I have a MBA connecting via HDMI to Samsung Monitor. Problem is desktop background for Samsung monitor is not showing. There is only grey desktop and doesn't have any changes even I try to change the image of the desktop at System Preferences. Changes for the MBA desktop is ok. Is that a mountain lion bug?

share|improve this question
    
I have a somewhat similar setup (MBP and LG external) and haven't seen this problem when switching to Mountain Lion. When you go to the "Desktop & Screen Saver" preferences, does it show you two dialogs...one for the main screen and one for the "Secondary Desktop"? –  Phillip Mills Aug 5 '12 at 15:11
1  
Grey screen...are you sure you're not running an app in full screen mode? –  Samantha Catania Aug 5 '12 at 15:25

3 Answers 3

OS X allows you to select different images for each display. When you open the Desktop section in Desktop & Screen Saver Preferences, you should get one dialog on each screen for choosing a desktop image. Each dialog controls only the image for that screen, so make sure you're setting the image you want on both screens.

share|improve this answer
    
This setting doesn't seem to save if I disconnect and reconnect the second screen (like when I leave from work and take the laptop home but plug it back in tomorrow). –  powerj1984 Nov 15 '12 at 14:40

Restarting the Dock seems to work for me, however I don't know what is causing this grey desktop background.

To restart the Dock, type this into Terminal and press enter:

killall Dock
share|improve this answer
    
This fixed it for me. Thanks. Pretty strange Mountain Lion bug. –  Gerald Kaszuba Nov 25 '12 at 22:27
    
Worked instantly, great tip. Have been wondering about this for months. –  Matt Gardner Jan 13 '13 at 22:15

I also experienced this problem and found this workaround:

  • Open System Preferences -> Displays -> Arrangements
  • switch on "Mirror Displays" and switch it off again

This is no solution for the problem of course, but at least the wallpaper is showing again without rebooting...

share|improve this answer

protected by Community Oct 23 '12 at 11:08

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.