Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I have a MacBook Pro with Mountain Lion 10.8. I am connecting to the Internet via a USB Internet Key. I enabled internet sharing via WiFi.

My friend has a MacBook Pro with Lion 10.7.

When I enable WPA2 Personal with a password, he gets "connection timeout" when clicking on my network name (even before entering the passcode). When I select "none" for security (no passcode), he has no issues connecting.

By request, I've added a screenshot showing that my only options are WPA2 or 'None': enter image description here

share|improve this question
    
Note that a iPhone was able to connect to my network without problems. –  nute Aug 19 '12 at 14:36
1  
Checkout: tidbits.com/article/13158 for details on how Mountain Lion changed internet sharing and issues with using WEP. It indicates, WEP will be allowed if you hold down the option key. –  Tony Lee Aug 26 '12 at 19:04
    
Which version of Lion is running your friend's MacBook Pro? –  daniel Azuelos Sep 11 '12 at 21:48
    
I wouldn't advise any return to WEP. WEP is simply false security! –  daniel Azuelos Jan 1 '13 at 10:43
add comment

3 Answers 3

To try to make things clear let's say you have 2 Mac named:

  • Alex
  • Bob

Here is the scheme of your small home network :

Internet --- USB --- Alex --- WLAN --- Bob

If when Bob try to join the wireless network (AirPort or WI-Fi or better WLAN) initiated from Alex, it gets an immediate rejection, this may be due to a network access with the wrong security setting.

To check this hypothesis, on Bob, simply go within:

System Preferences… > Network > WiFi > Advanced…

and look at the column Security.

If it is anything else than WPA2 Personal, double click on this network setting to fix it.

If it is already WPA2 Personal, double click on this network setting to check if the registered password is OK.

share|improve this answer
add comment

When you use Internet Sharing over Wi-Fi, you create an ad-hoc Wi-Fi network. Ad-hoc Wi-Fi only supports WEP for encryption on Lion and earlier. You can’t use WPA2 to encrypt an ad-hoc Wi-Fi network unless you are running Mountain Lion.

Edit: I see that you are using channel 36, that means 5GHz Wi-Fi. Try switching to a 2.4GHz channel (1-11, where I live).

share|improve this answer
    
Yet, when creating my ad-hoc network the only options were "none" or "wpa2 personal" –  nute Aug 5 '12 at 13:09
    
That’s very unusual… Can I get a screenshot of the screen where you configure the network with the security menu open? –  duci9y Aug 5 '12 at 13:27
    
see updated question –  nute Aug 5 '12 at 14:50
    
changing the channel didn't help –  nute Aug 13 '12 at 11:49
1  
Of course, since as you indicated it, your network was working on this channel 36, but with security off. –  daniel Azuelos Nov 24 '12 at 17:33
show 2 more comments

Change security from 40 to 128-bit.

share|improve this answer
    
where do you see 40 or 128?? –  nute Aug 8 '12 at 14:54
    
This setting was relevant with WEP. –  daniel Azuelos Jan 1 '13 at 10:42
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.