Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I have the AppleTV connected via WiFi. I tried AirPlay via WiFi using my iPhone and it mirrored perfectly. The next day, the AppleTV was sleeping before I turned it on using the Apple Remote. However, the option to mirror my iPhone (or even my iPad and MacBook) is not there anymore! I tried using the AppleTV via the remote and works fine, it's just that the AirPlay option is gone.

Why is that?

Unplugging the AppleTV from the power source and plugging it back in got the AirPlay option back. Is there a way to make sure this doesn't happen again ?

Edit: Using an Ethernet cable fixes the problem, however I do not wish to keep it wired. Why would the AppleTV have problems only on wireless?

share|improve this question

10 Answers 10

It's hard to say for sure, but I'm guessing there was a problem with the network discovery service. Apple uses Bonjour to advertise various network services (iTunes sharing, file sharing, AirPlay support) without the need to manually input configuration data. Unfortunately it can be a bit prickly at times, so if somewhere along the way the "Hey, I'm an Apple TV" message got lost, didn't get sent or received by your iPhone or Mac, it won't show up as an available device.

Unfortunately, the way Bonjour broadcasts the data seems to be a bit temperamental at times. I'm not aware of any real fix, but a restart almost always seems to fix it. If you're on a Mac, you can try restarting the daemon responsible by running the following two commands in Terminal:

  • sudo launchctl unload /System/Library/LaunchDaemons/com.apple.mDNSResponder.plist
  • sudo launchctl load /System/Library/LaunchDaemons/com.apple.mDNSResponder.plist

But that will only fix things if the problem is the Mac not receiving the messages properly - if it's on the Apple TV's end, then restarting that is the best fix.

share|improve this answer
    
I put the ATV to never sleep, but when my laptop goes to sleep the airplay icon is gone. Same thing for iphones and ipads. This is frustrating, the ATV is useless if I have to keep restarting it to work. –  Render Aug 5 '12 at 18:40
1  
The various Apple wireless routers have a function named Bonjour Proxy which remembers Bonjour announcements for sleeping devices, and wakes them up if needed. Strongly recommended. –  Thorbjørn Ravn Andersen Aug 25 '12 at 11:34

When the AppleTV wakes up, the icon should show up again very quickly.

If you have a router with Bonjour Proxy (like Airport Extreme or Time Capsule) they remember the Bonjour announce even while the AppleTV sleeps and can wake it up when needed.

share|improve this answer
    
I dont think I Have a router with Bonjour proxy .. I put the ATV to never sleep and the problem persists . –  Render Aug 5 '12 at 18:40
    
Does it persist if you connect with cable? –  Thorbjørn Ravn Andersen Aug 5 '12 at 19:02
    
I haven't tried connecting an ethernet cable to the ATV yet (due to location constraints) .. Would that fix the problem though ? –  Render Aug 5 '12 at 19:09
    
No idea. Try..... –  Thorbjørn Ravn Andersen Aug 5 '12 at 19:10
up vote 0 down vote accepted

Sadly using an ethernet cable did not really fix the problem !!

The way I managed to fix it is to get a new router with dual band signals. Having both 2.4Ghz and 5Ghz supported devices around the house, the router managed their connections efficiently. Note that the iphones use 2.4Ghz and the AppleTV uses 5Ghz. So the solution that fixed MY problem regarding the airplay option is to get a new dual band router.

share|improve this answer

try stopping any services that uses port 80 of your network. In simple terms disable anti virus firewall, Teamviewer and Skype. Restart the device and try again. This is a common problem. Hope this helps.

share|improve this answer
    
AirPlay doesn't use port 80, neither do TeamViewer or Skype use ports which could lead to conflicts. Can you please elaborate how stopping them would help? –  patrix Apr 3 '13 at 20:13

The reason may be that after the Apple TV had its major update it turned Airplay off. Just go to Settings>Airplay and turn it back on.

share|improve this answer

I found when i changed router to an airport extreme it fixed the issue. I had airplay working fully on iphone 5 but nothing on my mac.

share|improve this answer

if it's not an internal error, sometimes it's just a glitch. I usually just close the laptop and then open it again. This allows your computer another chance to look for devices and networks.

share|improve this answer

I had the same problem. I just turned Wi-Fi off and on again and the icon was back! Magic!

share|improve this answer

It turns out that you can fix this problem by going to your Settings app and selecting General -> International -> Language. Then change your language from whatever you are using now (such as English) to another language (I chose French). Then switch it back to your original language.

That's it. Now when you double-click and the Home button and then swipe twice from left to right, you should see the AirPlay icon.

share|improve this answer

I had the same problem. My iPhones streamed to Apple TV no problem but the AirPlay icon simply disappeared on the MacBook Pro with the settings saying that there was no device detected.

Finally sorted it out: I had McAfee Firewall and as soon as I disabled the Firewall, the AirPlay icon appears again! Not sure if this applies to you.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.