Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

On my home network, I have a NAS I regularly use for storage.

I have set my Mac to automatically mount it via a login item to open the directory on the System Preferences/Users & Groups pane.

I also use my Mac at work, though, where I can't access the NAS any more, because it's on a different network.

This means I get a ton of persistent "There was a problem connecting to the server" messages. I can close them, but they pop back up again.

Is there a better way to do what I'm doing, or to disable those messages?

share|improve this question

2 Answers 2

up vote 3 down vote accepted

What you need is a network location manager program, typically these allow you to perform certain actions (e.g. connect to a network drive) when the machine is on some networks and not on others. Several years ago I was using one, now defunct, so I can't recommend any from experience. What I found now are things like Sidekick ($29), Control Plane (free).

You can also do this with a script (e.g. Login Item, if you log off or shutdown the machine when moving it from home to work or vice versa, or cron job) to determine the network the machine is on and depending on it to connect to the network drive (if not already connected) or not.

share|improve this answer

I had the same problem and solved it this way. Go to SYSTEM PREFERENCES / USERS & GROUPS , there, select your user name and then click on LOGIN ITEMS. Check whether in this list there is a network drive, such as a share on your NAS. If yes, it means that your Mac is automatically trying to log on to that drive on starting up your computer.

On my Mac I had a connection to a network share on my NAS. After removing it, the "There was a problem connecting to the server" messages stopped immediately, even with the NAS switched off.

share|improve this answer
    
I think he is totally aware of that fact. The problem is more focused on how to avoid the message if the laptop is not at home, but keep the auto-login if he is. –  YoshiBotX Jun 11 at 20:14

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.