Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

In Lion I always used Control ⌃+Shift ⇧+Eject ⏏ to put my display to sleep when I walked away from my computer. The system would continue running and not go to sleep.

Now in Mountain Lion when I put the display to sleep, the system sometimes decides to go to sleep as well.

It does not happen all of the time, it has been rather unpredictable. Some times I walk away for 2 minutes and come back and it went to sleep entirely. Other times I walk away for hours and come back and it did not go to sleep.

Very odd. Any ideas?

EDIT

Screenshots for both Power Adaptor and Battery Energy Saver settings.

enter image description here

enter image description here

Also I just experienced the issue again. I walked away for about 3-4 minutes and came back and WiFi was disconnected so it does not seem like the Energy Saver settings are being respected.

Unless... Energy Saver is considering the 15 minutes have elapsed being that my Display has gone to sleep and is therefore kicking in the computer sleep Energy Saver setting? I will up the Computer Sleep and see what happens.

share|improve this question
1  
Is there any correlation between what apps you have running when you lock the screen and it sleeping? Siracusa's review mentions that apps must specify that they don't want the system to sleep for the system to not go to sleep. Maybe you have a set of apps that aren't specifying no sleep so your system is going to sleep inordinately rapidly. Also: what are your Energy Saver settings? –  CajunLuke Aug 3 '12 at 0:24
1  
Yeah, a screenshot of your energy saver settings would be pretty helpful. –  Jason Salaz Aug 3 '12 at 0:41
    
This isn't an answer, because I can't comment on your question. I'm actually having the same issue. It seems that it isn't only the Control+Shift+Eject that causes the system to sleep on display sleep. I have a bettertouchtool hotkey set up to sleep display using FN + tap top right trackpad and it does it there as well. Even only after stepping away for about 2 minutes. I'm also running a retina display, if that maybe has anything to do with it. Are you running one as well? This problem is actually quite annoying. Here's a screenshot of my energy saver preference panel: i.stack.imgur.co –  jackyyll Aug 4 '12 at 12:33
    
Updated with screenshots and a theory. It's interesting too. Even though I have not adjusted my ES settings after upgrading (maybe the upgrade changed them?) My computer never really seemed to follow these rules before when I used this method of locking my computer. Perhaps there was a bug before that has now been "fixed". –  Chris Wagner Aug 6 '12 at 21:36

2 Answers 2

Realised I answered a dupe of this here: How can I download something with display turned off (Ctrl+Shift+Eject)?

My answer to that question below:

I always use this combo as well, however this does not immediately sleep my machine in ML.

I believe this is a separate issue at play here. According to Siracusa's ML review, unlike in previous OS X versions, in 10.8 your system is eligible for sleep immediately upon "user inactivity" (the inactivity delay being set in your energy saver settings) unless the currently running apps make "power assertions".

In this case, that key combo is signalling to the OS that "user inactivity" should be triggered right away. In such a case, if your particular app that's downloading stuff does not make power assertions, your system will sleep.

I have come across the same issue generally (not necessarily related to triggering the screen sleep combo). See: Mountain Lion sleeps too aggressively

share|improve this answer

I may not have entirely understood your question because I haven't used Mountain Lion yet.

http://www.macupdate.com/app/mac/26234/sleep-display/

This app sleeps the screen while the system is still running. I'm not sure about Mountain Lion but according to the comments this will work on Lion at least. You could give it a try.

I set it to a shortcut for when leaving my desk. I usually walk away while booting too so I also put it in my startup items.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.