Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I'm running Lion, soon to upgrade to Mountain Lion once I can ensure compatibility with installed apps, on an MBPR, and in the meantime I'm being driven crazy by the keyboard backlight. Here's the deal: you may have heard about people who have issues with an undersensitive ambient light sensor, viz.: people turn on "automatically illuminate keyboard in low light" in System Prefs -> Keyboard, and then find that the light comes on too frequently.

They are helpfully informed to disable the automatic illumination, and manually to turn the light off using the F5 and F6 keys (actually, technically, the keyboard light down and keyboard light up keys when not using fn modifier).

Here's the funny thing: I have the "automatically illuminate" setting turned OFF, and I use the keyboard light keys to turn the keyboard light off.

Yet within a second, the light is back on.

Seriously!

Procedures to reproduce:

  1. Be doing anything
  2. Keyboard light is on
  3. Press keyboard light dim button -- but whatever is reporting the keyboard illumination level thinks the keyboard light is already off: Screenshot displaying keyboard illumination level of 0
  4. Press keyboard light increase button -- the light actually ends up dimmer, because it increases its illumination to one unit from what it thinks is 0 but is actually something higher.
  5. Press keyboard light dim button again -- keyboard light switches off for a split second.
  6. ???
  7. No profit. The keyboard demons switched the light back on during step 6, and now the light is on again.

Once again: I have automatic illumination DISABLED [please don't make me upload another screenshot to prove it:) ].

Frankly, I don't need keyboard illumination. It's occasionally useful in pitch black, but I touch type anyway, so it is usually just an annoying distraction and waste of battery.

So, I'd like to just turn the darn thing off permanently. Terminal commands appreciated!

Addendum: Apparently, the behavior does not repeat when plugged into power.

Addendum 2: Apparently, the behavior does persist when plugged into power; it just takes longer for the computer to realize that it has stopped annoying me.

share|improve this question

1 Answer 1

I know this isn't the answer you're looking for, but have you tried resetting the pram and smc? That might solve your problem without permanently killing the backlight

share|improve this answer
    
Actually, yes, but thanks. I assume (though I don't know a thing about this) that it doesn't make a difference to do so twice.... –  Philip Aug 3 '12 at 2:14
    
Depends... On older machines you seemed to have to reset pram several times to really clear it, I know that doesn't sound like it makes alot of sense, but most people observed the same. –  InfluenceJamie Aug 3 '12 at 2:21
    
Interesting. Maybe I will give that a shot sometime in the next few days. –  Philip Aug 3 '12 at 2:43

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.