Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

MBA 11" 2012 model, ML upgraded from Lion

User accounts:

  1. admin
  2. admin
  3. normal user
  4. guest

Working fine for a week or so. Was logged in as 3. (a regular user), and asleep.

When trying to resume the next day, it showed the desktop and just as it became interactive it crashed with a kernel panic - first one I've had.

At the login screen, where all four accounts used to be visible, now only 1. and 4. are available.

In the users & groups system config dialog all accounts are present and look fine. I can log into accounts 2 and 3, but only if I switch user whilst logged into account 1.

Any ideas? Very confused and I don't know enough about how user profiles are built in osx to know what to look for.

share|improve this question
    
Thanks for the tags jmlumpkin - didn't think to hyphenate! –  Robbo Aug 2 '12 at 13:15
add comment

3 Answers 3

Your first triage step is to isolate software from hardware. You could install ML clean on an external drive and see how it works or just erase your Mac and reinstall. Once you've concluded the hardware and base OS is stable, you can try the migration / restore from backup again or start narrowing down software corruption as a cause.

Assuming you can make the kernel panics happen - once you have 4 or 5, the stack trace should point to a pattern of where the system is having problems. If you can't reproduce the panic, then you may just need to clean up from a hard landing by restoring from a time before the unlucky crash.

share|improve this answer
add comment

Some questions come to mind.

  1. Do any of the user accounts have FileVault enabled? Some FileVaulted user accounts may have been slightly damaged during the panic.
  2. Have you tried to boot into Safe Mode? This often helps verify if third-party software is causing the issues.
  3. Did verify your disk with Disk Utility by starting from the Recovery Partition? A useful step for further troubleshooting.
share|improve this answer
add comment

It looks like a permissions issue. Boot into your Mountain Lion installer. First repair permissions from Disk Utility in the Utilities menu. Then, open Terminal and type “resetpassword”. Select your disk and then the affected user accounts, and click on Reset ACLs and permissions at the bottom of the window.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.