Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

After upgrading from Lion to Mountain Lion, my MBP does not show icons for external drives on the desktop any more. In the Finder preferences, “External disks” is checked under “Show these items on the desktop”. Any ideas?

share|improve this question
1  
Alex, I still see external drives icons on my desktop. Can you confirm that the external drive(s) are accessible within Finder in the left column? The only time that my icons disappear is when the drives aren't mounted. –  JW8 Aug 1 '12 at 18:28
    
Same here; it works fine for me. The problem you're having isn't with Finder. –  qegal Aug 1 '12 at 19:37
    
Try 'unsetting' the preference, logout, the reset the preference. –  IconDaemon Aug 1 '12 at 20:35
    
@JW8, yes the drives are fine. They appear in the Finder sidebar and under /Volumes; and they work just fine. –  Alex Aug 2 '12 at 10:26
    
@IconDaemon, thanks for the suggestion. Unfortunately it did not help. –  Alex Aug 2 '12 at 10:27
show 1 more comment

5 Answers

Somehow, the upgrade to Mountain Lion enabled the hidden Finder setting that completely hides desktop icons. You can reenable it using

defaults write com.apple.finder CreateDesktop -bool true
share|improve this answer
add comment

There's a much easier way of doing this. Go to Finder-->Preferences and the select the items you want to show on the desktop. Options are hard disks, external disks, "CDs, DVDs, and iPods," and Connected servers.

share|improve this answer
1  
This is independent of the setting I mentioned. – Yes, if you disable the external disks in the Finder Preferences, they won’t show up either. So the preference you point out may help. It is incorrect, however, that this is "much easier", because it is unrelated. –  Alex Oct 27 '12 at 16:24
add comment

I had a similar problem. After upgrading to Mountain Lion on my iMac, Finder would display my external hard drive icons on the desktop, but would not list them in any Finder windows, including upload windows opened by websites (ie blogs, Facebook).

After viewing Xavi's Youtube link (thank-you Xavi! http://www.youtube.com/watch?v=E8tqZSBs-4k), I discovered that Mountain Lion hides a number of items from appearing in your Finder window and sidebar by default.

Just go to Finder>Preferences>General and look for the 'New Finder Windows Show:' option, and choose 'All my Files'.

Also, you'll want to go to the Finder>Preferences>Sidebar tab and make sure that your external drives are check marked, not ticked (-). Hope this helps!

share|improve this answer
add comment

Aha! Just after posting my own frustration with this problem, and how none of the solutions provided here were working for me, I noticed one stray white pixel at the top left of my screen. Turns out it was the edge of the text name of a missing drive icon.

It appears that some drives are mounting with their icon at the screen origin (or possibly even further offscreen).

Try using "Clean Up By Name" to bring the drive icon back onto the screen. If that fails, this might work:

  1. Click anywhere on the desktop.
  2. Type the first few characters of the name of the missing drive.
  3. Hold the Shift ⇧ key and click on another icon.
  4. Drag the second icon around and see if the missing one is coming along for the ride.
share|improve this answer
add comment

The same happened to me and i found this on YouTube. I hope it helps!

http://www.youtube.com/watch?v=E8tqZSBs-4k

share|improve this answer
2  
Answers on Ask Different need to be more than just a link. It's okay to include a link, but please summarize or excerpt it in the answer. The idea is to make the answer stand alone. –  Daniel Lawson Aug 28 '12 at 12:26
add comment

protected by Community Mar 6 '13 at 18:58

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.