Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

In Calendar, I have a number of "iCloud" calendars that I share with my wife. ("Family", "Me", "Her", etc.) so we can see when we're both free/busy.

While I do want to see her whole schedule on my calender, I don't necessarily want a pop-up notification every time she has a surgery. (I'm not a bad husband; she's a surgeon.)

Is there some way to set different notification settings for individual calendars within a calendar account (in this case, iCloud)?

share|improve this question
    
Possible duplicate (of): Hide specific calendars from Notification Center –  iolsmit Dec 16 '12 at 11:00
1  
Not a duplicate: this is about Mac OS X; the linked question is about iOS. –  stephenwade Dec 22 '12 at 19:30
add comment

3 Answers

On the Mac side, I solved this by using BusyCal 2.

  1. In System Preferences "Notifications", turn off all Notifications for both Calendar and BusyCal
  2. In BusyCal Preferences, under "Alarms", turn on "Show Alarms" and select "use BusyCal Alarm window".
  3. In BusyCal select the offending calendar(s), and "Get Info" under the "Edit" menu. In the popup window under "Subscribe Options", select "Ignore Alarms".

I'm using iCloud and I much prefer the Alarms dialog under BusyCal to the systems notification center.

There is a 30-day demo of BusyCal for testing and the app is on "sale" until 12/31/2012.

share|improve this answer
add comment

In Calendar.app, you can right-click on any calendar, and choose Get Info. From here you can select Ignore Alerts

share|improve this answer
add comment

From what I can tell, it seems that there is no solution at this time. Over four pages of reports on discussions.apple.com and it seems that iCloud is broken for notifications in this manner on iOS.

The people it affect most is married couples. Ha. One possible solution involves calling Apple support. If you read through you will see on Oct 17th the person who was having the issue got a call back from Apple and they reset their Apple account. Many people are complaining that the option to save isn't working right now, it is a bug, apparently.

You can try to call and see if that will work. Good luck.

https://discussions.apple.com/thread/4339714?start=0&tstart=0 Here is a resolution from the discussions thread.

Through iCloud.com -> Calendar -> Preferences -> Event Updates: the ability to tick/untick "Email me shared calendar updates" seems to save now when I log out and > log back in (that setting never used to hold). I have now turned this off for my partner and he no longer receives email notifications (although it does still appear > in the Invitations tray on the iPhone Calendar app which is annoying).

My partner and I also share Reminder lists (a grocery shopping one, jobs on our home > reno etc) and after the iOS6 update on our iPhone's we lost the ability to
share/unshare these lists. Through iCloud.com -> Reminders you can now hover to the > right of the list name and a share icon is revealed where you can share/unshare the > reminder list with someone. Since iOS6 we also started receiving email notifications > everytime something was added to a shared reminder list (ie. Tomatoes) which was effing annoying. This seems to have stopped =)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.