Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

My OS X does not allow me to update to current XCode software.

With the new XCode and iOS SDK, the sourcecode is compiled with a newer compiler which has some new syntax options which are missing on my old platform.

That's why I need your help to get the new compiler to run with my XCode if possible.? Any idea or tip?

OS X 10.6.8 XCode: 3.2.6 I tried any XCode 4 setup, but it worries about the OS X version and does not allow me to upgrade :-(

The feature of the "new" compiler: ARC

share|improve this question
1  
Can you please be a bit more specific? Which OS X version and which XCode version are you currently running, which XCode or compiler version are you looking for? –  patrix Aug 1 '12 at 8:07
    
the details can be found in the post now. –  ledy Aug 1 '12 at 8:33
    
What exactly do you need - for SL 3.2.6 is the last one you can get for free –  Mark Aug 1 '12 at 9:45
    
I need ARC support. The other features of the IDE don't matter to me, but the syntax of sourcecode with ARC must run. –  ledy Aug 1 '12 at 11:35
add comment

1 Answer

XCode 4.2 will run on Snow Leopard and it has ARC support.

Go to Apple Developer Downloads and search for XCode 4.2 for Snow Leopard, it will show up there, at least if you're a registered iOS developer.

Any newer XCode version than 4.2 is not supported by Apple on Snow Leopard, so I suspect you may have problems even if you'd manage to install it.

share|improve this answer
    
There is only Xcode 3.2.6 and iOS SDK 4.3 for Snow Leopard offered to me. With Xcode 4.2 it is Lion only in the list and search results. –  ledy Aug 1 '12 at 9:34
    
@ledy id you have only a free developer account then it will not show but surely you have a paid developer account as you need that to publish an IOS app –  Mark Aug 3 '12 at 12:58
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.