Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I often use the "Library" folder in my home folder ~/. The Library folder there (~/Library/) is shown (unhidden), and that is not the question.

I would like to also always show the menu point "Library" in the Finder menu under the word "Go". Normally it only shows when I hold the Option ⌥ key the menu is open. I tried to assign "Library" to the shortcut for "Downloads" and gave Downloads another shortcut, like it worked for "Save As…". But it only shows up then holding down the Option ⌥ key.

How to always show the "Library" menu point under the Finder "Go" menu, without holding down a key?

In the screenshot I am holding down the Option ⌥ key:

the menu while holding the option key down

share|improve this question
    
Usually assigning a custom shortcut to a secondary menu item would do that, but it doesn't seem to work in this case. –  ؘؘؘؘ Jul 31 '12 at 9:37
    
I don't have access to OSX to test, does it work if you make the folder unhidden using chflags nohidden ~/Library? –  Alex L Jul 31 '12 at 9:50
1  
Like I said in the question, the folder ~/Library/ is unhidden. I can see the folder in Finder with no problem, therefore I also wanted the menu point to be always shown. –  user8551 Jul 31 '12 at 11:12
    
My workflow involves using Alfred (or quicksilver), it's like spotlight. I just press CTRL + Space, and typing Library and hitting enter. –  Doug Aug 3 '12 at 20:49
    
Not exactly what you want but it might be helpful: hold the option key and get your Library folder open. Drag the proxy (in the Library window's titlebar) to a Finder window's sidebar. That will give you quick access down the road. Handy when you're in an Open or Save dialog box and need to get to your Library folder. –  user26834 Aug 6 '12 at 2:39

3 Answers 3

This can only be fixed on Lion, not Mountain Lion:

Open System Preferences > Keyboard > Keyboard Shortcuts

In application shortcuts on the left, add an entry for Finder.app named Library (I used option+command+L) and you should see it in Library - again only for 10.7 Mac OS X Lion.

share|improve this answer
    
As you can see in the screenshot, I used the same shortcut months ago. Seems like the problem only occurs on mountain lion. –  user8551 Dec 3 '12 at 17:40
2  
I can confirm that on Mountain Lion - adding a shortcut does not make Library show in the menu (however the shortcut works as expected even though you don't see Library or the shortcut in the menu). –  bmike Feb 20 '13 at 18:05

There is no system-tweak-able setting (for now) that will change the "Go" menu behaviour.

Basically, whether you have a shortcut defined to open Library or not, you'll have to hold "Option" to make Library visible in the menu.

Alternatives from the comments for quick access to Library (as a workaround to it appearing) are to

  • add ~/Library to your Finder toolbar
  • add ~/Library to your Finder sidebar
  • define a Finder keyboard shortcut
  • unhide the folder with chflags nohidden ~/Library
  • automate typing ~/Library and use Go To… Command-Shift-G
  • place the folder in the Dock or an alias to it on the Desktop (or elsewhere)
share|improve this answer
    
Quick Acces isn't the problem, as you can see in the screenshot I have assigned a shortcut. I want that the library option in the menu shows up. –  user8551 Aug 5 '12 at 10:23
    
chflags nohidden ~/Library is exactly what I was looking for. Thanks. –  Matt Ball Mar 23 '13 at 17:24

This isn't exactly what you've asked for, but it's as close as you can get for now. Open Terminal (in the Utilities folder) and type this command, and the Library folder will be visible in your home folder as it always was before Lion. The setting should stick until the next time you install an OS update, at which point Apple will "fix" the invisibility flag for you. Just do this again at that point, and all will be well.

chflags nohidden ~/Library
share|improve this answer
1  
This helped me. I couldn't understand why I could no longer see my Library folder. +1 –  cosmicbdog Oct 18 '12 at 9:03

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.