Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

 Computer only | Duplicate | Extend | Projector only

Preferably without having to reboot etc, use magnets, or open/close the lid + waking it via USB peripherals I would like to have my MacBook display in "projector only" mode. Ideally, I'd like to be able to move already-on MacBook from the lounge to my desk, plug in the external display, and have it work with minimal fuss while still using the MacBook keyboard and track-pad.

Windows 7 really nailed this feature. Winkey + P is all you need to swap between modes.

Is it possible to disable the Macbook display and use only the external display, a la Windows 7's projector only mode?

share|improve this question
    
This really does just equate to turning off your MBP display--assuming the display settings for the projector are the way you want them. There is a key for that. –  ephsmith Aug 11 '12 at 21:55
3  
@ephsmith If by "turning off" you mean "reduce brightness to 0", then this is too much of a hack solution. –  Thomas Aug 12 '12 at 5:33
    
why do you think so? The only difference between turning off the display and setting brightness to 0 is that the LCD matrix is still active. –  ephsmith Aug 12 '12 at 14:16

4 Answers 4

It is possible to disable the internal display. Unfortunately this cannot be done without disabling the keyboard and trackpad as well. If you have an external keyboard and mouse this will work, however.

  1. Shut the lid of your MacBook.
  2. Plug your MacBook into an external power supply.
  3. Plug your external monitor in.
  4. Plug your keyboard and mouse in.
  5. Press any key on your external keyboard.
  6. You can now use your external screen without your internal screen being activated.
share|improve this answer

In 10.6 and earlier the internal display should stay off if you:

  • Close the lid
  • Press a button or key on an external pointing device or keyboard (while the laptop is connected to an external display)
  • Open the lid

See http://support.apple.com/kb/HT3131.

The behavior of clamshell mode changed in 10.7. The internal display turns back on when the lid is opened, so there is no way to use "projector mode" by default. You can restore the old behavior by setting the boot-args firmware variable to iog=0x0:

sudo nvram boot-args=iog=0x0

Applying changes requires restarting. The variable can be deleted with sudo nvram -d boot-args.

share|improve this answer

You might want to disable it by turning down the brightness to zero and put it in clone display mode. I think it would be equivalent. It is a trivial answer but it should work.

share|improve this answer
    
Clone display limits resolution options though, and turning the brightness down does not stop the cursor from entering that screen nor does it stop resources being used by that screen. Thanks anyway :( –  Thomas Aug 12 '12 at 5:36
    
If you change the primary display to the other monitor, you should be able to get the other resolutions back. –  daviewales May 14 at 4:34

I am also in exactly the same situation and looking for such a solution. So far no luck. However, a workaround is to mirror the external display with the macbook, then press F1 till the screen's back light turns off.

share|improve this answer
    
Unfortunately that limits the resolution options :( Thanks anyway. –  Thomas Aug 12 '12 at 5:36

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.