Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

This is a very weird problem I'm having with my Messages app on Mountain Lion. I have two accounts: a Google Talk and a Jabber account that is linked to my Facebook chat. Whenever I open my Messages app, my connection to Google Talk works just fine, but there is always a connection error with my Facebook account. But my Internet is working fine (like, I'm able to browse to www.facebook.com just fine). It's not an account authorization problem (incorrect username/password), trust me. To fix the problem, I need to go into Preferences -> delete my Facebook Jabber account -> recreate the account -> boom, connection is working fine again.

But, as soon as I log off from my Messages app (by closing it) and re-opening it, the problem re-emerges. Connection to Google Talk works fine, but a connection error with Facebook again. Perhaps this is an issue with Mountain Lion's implementation of Messages; because it is a newer app than the battle-tested iChat, there are still some rough edges needing to be sorted out.

Anyone having any tips regarding this problem?

PS: I did try to look at this question: iChat + facebook disconnection

share|improve this question
1  
Are you able to solve the problem by just disabling and re-enabling the account? –  jtbandes Jul 31 '12 at 2:05
    
I've had this issue since the beta app. disabling and re-enabling like @jtbandes says works for me though –  FLY Jul 31 '12 at 7:05
    
What are the settings you are using in Messages for the facebook account - what server is it pointing at and which checkboxes are enabled? –  matt b Jul 31 '12 at 14:53
    
I have the server connections correct: server chat.facebook.com, port 5222. All checkboxes are unchecked! The error messages I keep receiving (in a popup): Messages lost the connection to the Jabber account “chat.facebook.com”. A network error occurred. Also, I shouldn't have to keep deactivating and reactivating the account in order to make it work. Please tell me if you disagree that doing so would be quite user-unfriendly and annoying. –  ecbrodie Jul 31 '12 at 22:47
add comment

3 Answers

up vote 7 down vote accepted

These steps fixed the problem for me:

  • Disable the account.
  • Check 'Automatically find server and port'.
  • Enable the account again.
share|improve this answer
    
Well...sometimes after doing this, the connection still sometimes barfs up. However, I realized that the quickest way to solve the problem at that point is to simply go to Messages->Accounts->uncheck and recheck chat.facebook.com. This will re-login and we are back! –  ecbrodie Aug 8 '12 at 14:24
add comment

To provide the solution I found: Sign in to Facebook on your browser, go to Account Settings > Security > Generate App Password

This will create a unique random password for you to use. Use THAT password instead of your actual FB password. Signed right in.

share|improve this answer
add comment

I was having the same problem, then I do this:

  • Disable account.
  • Go to Server Settings tab.
  • Uncheck: Automatically find server and por.
  • Uncheck: Use SSL.
  • Enable account again.

Now it works!, my settings:

  • Server: chat.facebook.com
  • Port: 522
share|improve this answer
    
That's bad joke dude, disable SSL for login. And port 522 !? –  sorin Mar 7 '13 at 9:41
    
I know, but, doesn't work when I check the SSL options, :S. –  nebiros Mar 8 '13 at 16:21
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.