Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I like how with inertia scrolling you can swipe harder to scroll further down the page, but what I don't like is how the scrolling speeds up quite a bit as you scroll. This was not the behavior in Lion, and it is causing me headaches while scrolling around my text editor trying to edit code as it will consistently scroll right past where I'm trying to go. I can't find any settings for this, any ideas?

share|improve this question
add comment

4 Answers

There no official specific settings to this, although with command line changes you can turn inertial settings on and off full stop. Unfortunately, especially if you like the inertial scrolling in part, the beth way forward for you is to understand how it works better.

I've nicked this sentence from the ArsTechnica review, as there is no point in re-inventing the wheel:

Finally, Apple has added iOS-style accelerated scrolling to Mountain Lion. The first three swipes on the trackpad scroll as they did in Lion, but on the fourth swipe, the distance traveled within the document greatly increases. This magnified ratio of finger movement to scrolling distance continues as long as the user keeps swiping repeatedly.

If you like inertial scrolling to a point, then perhaps a workaround is to only use it to a point. Stopping after 3 scrolls will prevent you from triggering the increased scrolling acceleration.

It's not exactly what you want to hear, but sometimes you need to work within the confines of the system if you wish to pick and choose which bits of scrolling behaviour you wish to apply or not. Perhaps further preference options will show up in the future (likely as command line changes), but overall you can probably imagine why they have made this change, because it's a good one for most (non-coding) users.

share|improve this answer
add comment

I couldn't find it either and it is highly annoying with a trackpad, especially with webpages that use infinite scrolling (like Facebook).

What I found to fix it - to a certain extend:

System prefs > Accessibility > mouse & trackpad > mouse or trackpad options > scrolling speed > slow. (keep inertia on)

share|improve this answer
add comment
up vote 2 down vote accepted

I just found this fix on GitHub. I've tested it and it does indeed work. I still wish Apple would just add a switch into the preferences pane.

https://github.com/davekeck/DisableExtremeScrollAcceleration

share|improve this answer
add comment

There is a small tool (DisableExtremeScrollAcceleration) that (according to the author) switches this behavior off:

After searching in the source code I think it should also be possible to just adjust the speed and thresholds without disabling it altogether.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.