Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Speak Notifications is set to OFF but it still will break mid paragraph and say "new notification from..." or "new text message from..." then I have to start the reading all over again.

This seems like a bug to me. It's especially annoying when the block of text is huge and can only be voiced in entirety.

share|improve this question
    
Please take the opportunity to tell Apple directly: apple.com/feedback/iphone.html –  Graham Miln Aug 12 '12 at 19:59
add comment

2 Answers 2

I use Voice Over all the time and if I understand it correctly the setting for Speak notifications in the VO settings is just to speak the notificatons when the screen is locked. Unfortunately the only way to have it not speak individual notifications is to turn each one off as there is no way to all notifications on or off at once. Hopefully ios 6 might remedy this with the do not disturb setting that is supposed to be included.

share|improve this answer
add comment

On an unmodified version iOS 5 you cannot set the voiceover function to have priority over notifications.

If you don't mind jailbreaking your phone, you may have some options to confiugure a "do not disturb" type functionality. This modification on cydia by Rob Melkhior seems to fit your needs, but I have no experience with it.

Hopefully your bounty will attract additional attention if someone has first-hand experience with this modification.

Short of a jailbreak, your only "out of the box" option is to disable notifications either when you don't want to be interrupted or entirely.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.