Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

In older OS X versions, this used to work just fine:

defaults write /Library/Preferences/.GlobalPreferences com.apple.mouse.tapBehavior -int 1

It would enable tap to click for built-in MacBook Trackpads for the root user, which would also affect the login screen. There are similar commands to enable it for Bluetooth-based Magic Trackpads as well.

Unfortunately it doesn’t seem to work in OS X 10.8 anymore. Is there some other way of doing this in Mountain Lion?

share|improve this question
    
Why the downvote? –  Mathias Bynens Aug 30 '12 at 6:31
2  
And why not down votes and comments on the wrong answers below that haven't been tried / don't actually work? –  bmike Nov 7 '12 at 14:47
add comment

7 Answers 7

I've had mixed results with enabling it for the login screen between my macs.

Here's how I have gotten it to work:

  1. Go to System Preferences (as an admin user) -> Users and Groups -> Login Options
  2. Click the lock and enter your admin credentials
  3. Next to Network Account Server click Edit (or add, what ever comes up if you don't have a server already set up) and then click "Open Directory Utility"
  4. Click the lock again and reenter your credentials
  5. In the menu bar, click edit and then click "Enable Root User"
  6. Set up a password for the user, and then log out of your current user
  7. At the login screen, you should have a "Other..." option next to your users. Type in "root" as your username and use the password you set up.
  8. Enable tap to click through System Preferences.
  9. Log out, and go back into your normal user, and open up Directory Utility again
  10. Click on the padlock to authenticate in Directory Utility, and then go to edit on the menu bar, and click "Disable Root User"

For security's sake, make sure you disable the root user!

Now I mentioned at the start I've had mixed results for this. It worked fine on my Mac Mini 2012, but it didn't seem to work on my MacBook Air 2011. The thing that I can think of primarily is that the MacBook Air's trackpad is built in and connected via USB, whereas the Mac Mini's trackpad is bluetooth.

Why does this matter, you ask? Did anyones else notice that the Terminal command that was used to change the system default to having Tap to Click on seems to store the setting in an entry that references AppleBluetoothMultitouch.trackpad?

If thats the reason, then that would be why some people report the terminal command works and others say it makes no difference.

I'm going to dig more in this, I wonder if there is a similar AppleUSBMultitouch.trackpad entry somewhere...

Edits:

  1. Just confirming, I connected my Bluetooth Trackpad to my MacBook Air (it is surprisingly difficult to remove a trackpad from bluetooth preferences on a desktop mac by the way) and I can Tap to Click on the login screen with the bluetooth trackpad, but not the built in one. Innerestin'!

  2. Oh, for comparison to your systems, both my Macs are running 10.8.4, have no startup items at all (I like my speedy boot times) and have no third party Kexts

share|improve this answer
add comment

On 10.8 the correct wording seems to be

sudo defaults write com.apple.AppleMultitouchTrackpad Clicking 1

(not sure if the -int switch is really needed). This does not turn on click-to-tap immediately and if somebody can tell how to apply that default, i'd be a happy little admin :)

share|improve this answer
    
I'd say -int is not needed, works here just fine without. –  Jawa Nov 1 '13 at 13:19
    
+1. I tested this on my 2014 Macbook Air with OS X Mavericks and it works. Note that sudo is needed even if you are using an admin account. (Before I changed the defaults, I opened the terminal from an admin account and typed sudo defaults read com.apple.AppleMultitouchTrackpad Clicking and then repeated the same command but without sudo. The former reported 0 while the latter returned 1.) The -int in -int 1 is to specify that 1 is an integer. Apparently the switch can be omitted but it doesn't hurt to include it. One may also replace the part -int 1 by -bool true. –  user1551 Jul 13 at 5:51
    
Anyway, in view of Howard's answer, it seems that one needs to change different domains/keys on different versions of the OS or different models of machines. –  user1551 Jul 13 at 5:52
add comment

Turns out you can add this as a function in the Terminal:

sudo defaults write com.apple.driver.AppleBluetoothMultitouch.trackpad Clicking -int 1

That worked for me, thanks to these guys - http://forums.macrumors.com/showthread.php?t=1218257

share|improve this answer
    
This worked for me on a MacBook Air running 10.8.4, both with the built in trackpad and a bluetooth Magic Trackpad. –  Mr Rabbit Aug 7 '13 at 12:28
add comment

Have you tried enabling dragging in System Preferences > Accessibility > Mouse & Trackpad > Trackpad Options?

(From How to change tap to click using "defaults write" from command line?)

share|improve this answer
    
Dragging doesn’t seem to have anything to do with this. I also don’t see any reference to this setting in the thread you linked to. –  Mathias Bynens Jul 30 '12 at 10:59
add comment

I haven't tried this myself, but this might be what you're looking for: sudo defaults write com.apple.driver.AppleBluetoothMultitouch.trackpad Clicking -int 1

share|improve this answer
1  
Just want to point out the following command does not work in 10.8 sudo defaults write com.apple.driver.AppleBluetoothMultitouch.trackpad Clicking -int 1 –  user26612 Aug 2 '12 at 16:57
1  
I found that one on MacRumors as well — but it doesn’t seem to work on OS X 10.8 either. –  Mathias Bynens Aug 6 '12 at 17:27
add comment

Are you talking about the "Tap to click"? If so you can enable and disable in

System Preferences > Trackpad > Tap to Click

share|improve this answer
    
At least for me it has changed. I'm using Mountain Lion –  J. Costa Aug 30 '12 at 9:59
    
Not for me. This only changes the settings for the current user, not the login screen. –  Mathias Bynens Aug 31 '12 at 6:32
add comment

System Preferences > Accessibility > Mouse & Trackpad > Trackpad Options > check Enable Dragging with/without Draglock.

share|improve this answer
    
What does this have to do with the issue at hand? How can this work? –  Mathias Bynens Oct 11 '12 at 6:01
add comment

protected by Community Nov 7 '12 at 14:46

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.