Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I would like to make Option+clicking the Volume icon in the menu bar show me all AirPlay output devices. Right now, only "Internal Speakers" and the last used AirPlay device are listed, so either only my Apple TV or AirPort Express:

Going into Sound Preferences I always see both the Express and my Apple TV. Only after selecting one there, it also appears in the Option+click menu, but then the other is no longer listed there. Also, whenever using AirPlay Mirroring (which has its own icon in the menu bar), the Apple TV is added and the Express disappears.

Any trick to make both available in one click? Or at least make the Express stick there? (I can select the Apple TV using the AirPlay Mirroring icon.)

share|improve this question
    
Ah, Option+F10, F11 or F12 opens Sound Preferences quite easily, and then using Tab, cursor keys, Command+Q is easy too. Maybe I should remove the volume icon altogether and rely on the keyboard instead. –  Arjan Jul 29 '12 at 14:40
    
If you have a satisfactory answer - feel free to answer your question and accept it. If you have an unsatisfactory answer, best to still answer but not accept explaining how it falls short. Someone can then correct, edit or answer as appropriate. –  bmike Jul 29 '12 at 22:18
    
I feel my comment is really just a workaround, and not answering the question, @bmike? –  Arjan Jul 29 '12 at 22:28
    
Opt-clicking volume has always shown me the full list of inputs and outputs. I feel you're in an odd situation. Try with a new test account. It might be an odd setting you have. –  Alex Aug 16 '12 at 2:43
    
Interesting, @Alex. Is one of your outputs an Apple TV? (Maybe that's causing things to be different, as it's also shown in the AirPlay Mirroring for the display.) I tried in the Guest account; no changes. –  Arjan Aug 16 '12 at 18:18
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.