Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Any time I open a new terminal window (independent of terminal app), the console stderr displays dyld: DYLD_ environment variables being ignored because main executable (/usr/bin/login) is setuid or setgid before the first bash prompt.

The start of this error coincided with my install of 10.8.

How can I get rid of that message?

Below is my .bash_profile:

export PS1="\u@MBP:\W ->"

# Your previous /Users/segiddins/.bash_profile file was backed up as /Users/segiddins/.bash_profile.macports-saved_2012-04-19_at_21:00:04

# MacPorts Installer addition on 2012-04-19_at_21:00:04: adding an appropriate PATH variable for use with MacPorts.
export PATH=/opt/local/bin:/opt/local/sbin:$PATH
# Finished adapting your PATH environment variable for use with MacPorts.
share|improve this question
In your home folder ~/ there should be a file called .bash_profile. Could you paste it somewhere and show us? – kba Jul 29 '12 at 2:01
up vote 2 down vote accepted

It seems that the problem might be with asepsis (If you have it installed).

Re-install it to make sure that it's up-to-date. And then Download the Command Line Tools from XCode.

That fixed it for me...

share|improve this answer
Just tried it and it worked for me too. – Maiasaura Jul 30 '12 at 20:10
I tried before tonight, then did again and saw why I didnt uninstall it-- asepsisctl uninstall doesn't exist. – segiddins Jul 31 '12 at 2:46
Thanks, re-install than asepsisctl uninstall did the trick! – segiddins Jul 31 '12 at 3:44
I don't have asepsis. Apparently a bug report has been filed: – charlax Sep 12 '12 at 9:43

I had this happen to me on 10.8.2 and just logging out then back in fixed it.

share|improve this answer

One option might be to upgrade to Mavericks. I had this error too while running Mountain Lion and after updating my system to Mavericks, it dissappeared.

share|improve this answer
This does not really answer the question. If you have a different question, you can ask it by clicking Ask Question. You can also add a bounty to draw more attention to this question once you have enough reputation. – Mark Oct 24 '13 at 12:53

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.