Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Whenever my rMBP wakes up from sleep, it shows a log in page with my user name. The page has a metallic gray background. After I enter my password, another page opens up with my wallpaper along with my user name again, and I have to enter the password one more time.

Output of diskutil list for /dev/disk0 is:

#:                       TYPE NAME                    SIZE       IDENTIFIER
0:      GUID_partition_scheme                        *500.3 GB   disk0
1:                        EFI                         209.7 MB   disk0s1
2:                  Apple_HFS Macintosh HD            499.4 GB   disk0s2
3:                 Apple_Boot Recovery HD             650.0 MB   disk0s3

How do I disable multiple login windows each asking for a password when my laptop starts or wakes up from sleep?

share|improve this question
add comment

2 Answers 2

up vote 2 down vote accepted

If anyone else tried bmike's method but didn't fix multiple logins, try the following :

  1. System Preferences
  2. Security and Privacy
  3. Unlock the settings using the lock button (buttom left)
  4. Advanced
  5. Disable "Log out after ## minutes of inactivity" option

Now you should only get one login screen after a screen saver or waking up, rather than logging you out and having to enter the password twice.

What I deduced from this is that it logs you out, and you have to enter the password to log in again. Then the lock to the desktop shows up, where you have to enter the password again to access the main desktop. Weird, if anyone knows another way to fix this please do reply.

share|improve this answer
1  
Thank you for posting this. I'll file a bug if I can reproduce this. Seems like the OS is resuming your exact state when that is total overkill... –  bmike Aug 1 '12 at 4:03
add comment

Disable File Vault if you don't want this two step log in process. You can be sure FileVault is off by seeing the following from terminal:

Mac:~ me$ diskutil cs list
No CoreStorage logical volume groups found

Alternatively, you could disable and re-enable the File Vault encryption and watch for the prompt where it asks if the OS user should be permitted to unlock the drive with the user's password.

If you select yes from that, the user will show up on the first login screen and both unlock the FileVault protected volume and log in with the same credentials.

share|improve this answer
    
File Vault is already disabled for me. However, when I go to Security and Privacy, then click advanced, there is an option that says "Log out after ## minutes of inactivity" .. would this be the problem ?? Kind of doubt it though. –  Render Jul 28 '12 at 16:52
    
Wow - that's odd. What does diskutil list show if you type that in the terminal. This clearly isn't the normal behavior - so it might take a bit to suss out what has gotten messed up. I wonder what a newly created admin user does when you let it sleep with only that user logged in. Also - you might add the OS level of your Mac to the question in case that helps... –  bmike Jul 28 '12 at 17:35
    
Also - you might want to try turning on File Vault to see if that assists in setting the keys that normally prevent this sort of two-step authentication dance. –  bmike Jul 28 '12 at 17:44
    
This what shows when I enter that code in Terminal : /dev/disk0 #: TYPE NAME SIZE IDENTIFIER 0: GUID_partition_scheme *500.3 GB disk0 1: EFI 209.7 MB disk0s1 2: Apple_HFS Macintosh HD 499.4 GB disk0s2 3: Apple_Boot Recovery HD 650.0 MB disk0s3 –  Render Jul 28 '12 at 18:25
    
Perfect. You could check that the same info is shown when you boot to the recovery HD and run terminal there, but it's looking like my FileVault guess isn't the cause of your glitch. –  bmike Jul 28 '12 at 18:28
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.