Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

In Mail.app 6.0 with 10.8 Mountain Lion, Apple has chosen to make it impossible to drag-select text in a message that has been sent or received. In previous versions, you could do as you can with every other single program that handles user-created text anywhere in the operating system (!!!) and put your cursor anywhere in the message, drag to highlight the text you want, and then, voilà, there'd you have a discrete selection of text that you could, say, copy.

Now, in Mail.app 6.0, when you try this in the body of a sent or received message, you instead get a little mail icon. Mail.app assumes you want to drag the whole message somewhere else! This is highly counterintuitive program behavior.

It is impossible to drag-select text in a sent or received mail message, as far as I can tell with the settings Mail.app currently has. The only approximation is to double-click on a word (which selects it; triple-click will select a sentence), then hold the shift key, then click on the end of the text you want to select, then copy or whatever as you like. But even with this method it is impossible to select just a part of a word.

How can I revert Mail.app 6.0 to the proper drag-select behavior that works absolutely everywhere else on the system? The way Mail.app 6.0 behaves for this is counter to my 24 years of history with the various Mac OSes.

UPDATE: It seems to have resolved itself. I am not sure what did it but now it behaves as it should.

share|improve this question
1  
I can't repeat this here, dragging in a message selects text as usual. Try to reboot and disable any addons. –  patrix Jul 28 '12 at 15:00
    
No Mail addons are installed. Rebooting did not fix it. –  Grant Barrett Jul 29 '12 at 3:06
    
This is something specific to your system, I can't reproduce it in four different Mountain Lion machines. –  Martín Marconcini Jul 30 '12 at 16:02
    
Can you specify your preferences and options with respect to message viewing? I am unable to reproduce the problem. I do agree this would be a very frustrating problem, but I'm running Mail 6.0 and have not been able to duplicate your issue. –  Daniel Lawson Jul 30 '12 at 16:25
    
This should be re-opened. This is very much a real issue (though clearly not reproducible by everyone). –  Evert Nov 16 '12 at 13:30
show 2 more comments

closed as not a real question by patrix, bmike Sep 16 '12 at 18:25

It's difficult to tell what is being asked here. This question is ambiguous, vague, incomplete, overly broad, or rhetorical and cannot be reasonably answered in its current form. For help clarifying this question so that it can be reopened, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

3 Answers

I had the same issue after upgrade to 10.8, had some old emails sitting open that I had minimized, closed all of them and then quit Mail. After restarting the issue went away, had previously tried to quit/restart/change layout with no luck.

share|improve this answer
    
Confirmed. Quitting Mail (right-click in dock -> Quit) and then restarting it made the problem go away. Note that rebooting the computer without quitting mail does not fix the problem. –  aroth May 13 '13 at 0:46
add comment

I had the exact same issue. Oddly, switching from Classic layout to the new layout "fixed" it for me. Problem now is, I hate the new layout..

share|improve this answer
    
Works for me with both layouts, did you try to switch it back? –  patrix Jul 31 '12 at 20:56
add comment

If you double click on the mail item in the list view, it will open in a new window. Then you can highlight the text properly.

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.