Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Under Mountain Lion, syncing Reminders to iCloud is linked to syncing Calendars for some reason:

enter image description here

In contrast, under iOS (version 5), you're able to sync Reminders to iCloud separately:

enter image description here

I sync my Calendars to a Google Calendar, and my Reminders to iCloud on my iOS devices. However, in Mountain Lion, this doesn't seem to be possible.

Is there some workaround to the limitation in the preference pane in OS X?

share|improve this question
    
FWIW, this is not an issue in Mavericks. –  Keen Aug 11 at 17:20

3 Answers 3

Yes you can. Just add your google account from System Preferences as usual. Then open iCal > Preferences > Accounts > iCloud and untick "Enable this account"

enter image description here

share|improve this answer
    
This didn't work. Reminders isn't pulling down my iCloud Reminders. –  Keen Jul 28 '12 at 20:04
    
@Keen, make sure Calendars & Reminders is still checked. –  Lukas Dec 31 '12 at 17:49

I, too, would very much like the OSX Reminders to be sync'd with iCloud separately from Calendar (I, too, sync my Calendar with Google Calendars). In testing out Keen's response, I found that if I leave my OSX Calendar enabled in iCloud, then look in OSX Reminders, I see all the same tasks as on my iOS devices. On my OSX Reminders, I added a task to one of the iCloud lists. Then, once again, disabled the iCloud Calendar account. Now, when I look at my iOS device, the task I added while on my Mac is there (and alerted me on my iOS device at the appropriate time).

So, temporarily enabling the OSX Calendar/Reminders sync with iCloud is a work-around...certainly not pretty, but do-able...until Apple improves OSX to separate the Reminders iCloud sync from the Calendar iCloud sync.

share|improve this answer

This works.. one more thing to make it safe - i.e. to retain your google calendar without a fuss..

  • Disable WIFI or unplug your Ethernet cable
  • enable Reminders & Calendar in the Cloud Setting in Mountain Lion
  • Open iCal, and iCal will attempt to Sync w/ iCloud and will eventually timeout
  • click "Try Again Later"
  • In iCal go to Preferences > Accounts > iCloud and untick "Enable this account"
  • Enable your WIFI/plug in your Ethernat cable
share|improve this answer
    
Additional note.. everything seems to be setup, but the reminders are still not syncing w/ iCloud. However the Google Calendar is still syncing as normal.. –  Luke Aug 9 '12 at 6:07

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.