Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I just updated my MBP to OSX 10.8 and am trying to start a new project with brunch.io which by default uses coffeescript and I prefer javascript so I need to clone the simple js skeleton. So something like this:

brunch new <someprojectname> --skeleton https://github.com/brunch/simple-js-skeleton.git

Which is what I have used previously and it worked fine. But today I am getting the following error:

error: Git clone error: /bin/sh: git: command not found

I really don't know how to fix this...

share|improve this question

1 Answer 1

up vote 3 down vote accepted

This error is caused by not having git installed. Your previous installation was probably lost in the update (don't worry, your repos will still be intact).

You can download git from its official page, here.

If you're a member of an Apple developer program you can also install git by installing the Xcode command line tools, found in the Downloads tab of Xcode's preferences.

share|improve this answer
    
Yep that worked. Thanks! –  Jonathan Miller Jul 27 '12 at 20:19
    
Thanks! it worked for me by installing the Command line tools from the Xcode. –  user72231 Mar 6 at 7:36

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.