Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I try to install the most recent (july 25) version of Command Line Tools (xcode44cltools_10_76938107a.dm), downloaded from https://developer.apple.com/downloads/, but are stopped with the error message "This package can only be installed on OS X 10.7 Install a version of the Command Line Tools that supports OS X 10.8."

But I can't find any better version; if such exist why isn't it on the Developer site?

share|improve this question
2  
possible duplicate of I apparently "do not have access to Command Line Tools" in ML –  patrix Jul 27 '12 at 19:00
    
You can install them from inside XCode, see link above. –  patrix Jul 27 '12 at 19:00

2 Answers 2

You can install the command line tools within XCode.

Open XCode and navigate to the preferences.

From here you have to go to the Downloads-Section. Here you can see the ability to install the command line tools:

enter image description here

EDIT: I can see the right command line tools on the download-page from Apple:

enter image description here

share|improve this answer
    
1. These are the command line tools I downloaded (as I said), and which wouldn't install (with the error message I mentioned). Have you verified that they work for you? –  Kåre Olaussen Jul 27 '12 at 19:19
    
The download from ADC worked for me - but it didn't work from inside XCode. –  Rene Larsen Jul 27 '12 at 19:25
    
2. It is somewhat overblown to download 1.46 GB code for the purpose of installing a much smaller package, but I did several times after first installing Mountain Lion. Unfortunately, I can't get Xcode 4.4 to run properly either -- it grows to consume 20+ GB memory, leaving the system unresponsive. –  Kåre Olaussen Jul 27 '12 at 19:31
    
Rene L: Could you really install the same version as I mentioned on OS X 10.8 (12A269)? –  Kåre Olaussen Jul 27 '12 at 19:42
    
@kåre - Yes, after I first tried from inside XCode, and I got the error, I downloaded the Command Line Tools from ADC, and installed it without any problems. –  Rene Larsen Jul 27 '12 at 20:00

The best way to find developer tools for your version of XCode is to click on the XCode menu, scroll down to "Open Developer Tool" then select "More Developer Tools..." which will take you to a website displaying the latest developer tools.

See my screenshot:

enter image description here

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.