Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I have attached two external monitors to my retina MacBook Pro:

  1. 24" Dell 1920x1200 with HDMI->DVI
  2. 19" Samsung 1280x1024 with Thunderbolt->VGA

While non-retina enabled apps look just fine (e.g. Blender) and seem to be pixel exact (monitors working correctly), all OS X rendered fonts seem to lack font smoothing or seem to have bad font smoothing. The funny thing is, that there seem to be two different kinds of font smoothing:

A black on white font with just black and white (font smoothing on the internal):

just black and white (Font smoothing on the internal) big2

and some with color (font smoothing on the external monitor):

With Color big

There is also some text smoothed with color on the internal, and folder names on the desktop are smoothed in black/white on both displays. The folder font on the external display still looks bad, though.

Short question: how can I improve this behaviour, e.g., get the font on the external monitor to smooth in black/white like Blender does it?

blender:

blender
enter image description here

same font size finder:

finder
enter image description here

Blender also always seems to get the straight lines in a font aligned with pixel lines. The problem is still there when working with the lid closed. I already tried to read

defaults -currentHost read -globalDomain AppleFontSmoothing

to get the current setting but it tells me it the setting does not exist.

share|improve this question
    
I will try to get make the font smoothing pictures bigger in a sec –  miceterminator Jul 27 '12 at 17:56
    
any progress with this issue? –  YSY Sep 25 '13 at 15:04

4 Answers 4

None of the LCD font smoothing options are going to do you any good, and here's what I suspect is the reason.

Subpixel rendering simply doesn't work with resolution-independence as implemented by Apple. If OS X renders everything on a much larger pixel grid and uses subpixel rendering, it would look fine if shown at native resolution. Instead, in 10.8, the graphics card scales the larger pixel grid down to what's displayable by the monitor. During the downscaling multiple adjacent pixels get averaged together and combined. For black text on a white background, this means that the red, red+green, blue+green, or blue subpixels on the edges of fonts (which give subpixel rendering its characteristic crispness) are averaged with adjacent white pixels during the downscaling. The subpixel effect basically disappears in the process and you're left with entire pixels colored funny around the text, and none of the LCD smoothing options look acceptable. Your best bet is to UNCHECK "use LCD font smoothing" in the System Preferences and let the graphics card antialiasing do the job instead. It's not as good as what we had before, but at least it isn't quite as fuzzy. The only way I could see this being addressed would be if the fonts were rendered on the native pixel grid after scaling instead.

Notice that if you zoom in using the OS X zoom feature, with LCD font rendering enabled, you see colored blocks around the fonts. But if you zoom all the way out and take a photograph of the screen using a camera, subpixel rendering is actually not taking place! I'm a bit surprised that Apple would leave the option in there when it clearly doesn't function as intended with external monitors.

Here is a picture I took of my external display connected to my rMBP with "flat panel" (sub pixel) font smoothing enabled. Notice that it's definitely not occurring, because entire pixels are being dimmed to the sides of characters.

share|improve this answer
    
I thought retina MacBook Pros wouldn't change the way text is rendered on external displays. But then again, what would happen if a window was partially on the internal display and partially on an external display? Are you sure that there was no subpixel rendering in the photos? Text would normally appear monochromatic when zooming in if it was disabled. –  ؘؘؘؘ Sep 24 '12 at 11:09
    
In my case, the text had colored fringes using software zooming, indicating that subpixel rendering was occurring, but viewed without the software zoom the subpixel rendering stopped occurring. This points to the system rendering everything on a much larger pixel grid (perhaps with subpixel rendering working there), but the benefits are lost in the downscaling. The benefit of this approach is that the rMBP does allow windows to straddle displays and look reasonable on both, just lower quality on the lower-res display. The anti-aliasing during downscaling even occurs with the mouse pointer! –  Corky Sep 25 '12 at 21:41
1  
The attached image appears to have expired, do you have a replacement? –  Pharap Sep 5 at 20:17

Applications like Blender or Photoshop just don't render text the same way as native applications. Subpixel rendering is also disabled for elements with a transparent background like the text for icons on the desktop.

You can disable subpixel rendering by unchecking System Preferences > General > Use LCD font smoothing when available.

There is no AppleFontSmoothing key by default in ~/Library/Preferences/ByHost/.GlobalPreferences*.plist or ~/Library/Preferences/.GlobalPreferences.plist. Setting AppleFontSmoothing to 0 would usually correspond to disabling LCD font smoothing in System Preferences. Setting it to 1 would make text lighter but keep subpixel rendering enabled.

share|improve this answer

It doesn't look quite as good as my 27 inch iMac, but something that helped me was to turn down the display's built-in sharpness setting to zero (Dell U2713H). This, combined with increasing the brightness, made my display look much better when plugged into my rMBP (running 10.9.1 at time of writing). It's a huge improvement!

(additional note, I'm plugged into the display with mini displayport)

share|improve this answer

Funny thing is that under Mac OS X 10.9.5 (Mavericks), the setting "LCD font smoothing" does not appear to have any effect. When I zoom in to text (control + swipe up), I always get the color fringes on my external Cinema display (driven by a Retina MacBookPro). That occurs apparently in all applications (I tried Safari, Mail, GVim, Finder, Microsoft Word).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.