Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Since the upgrade to Mountain Lion, I get blurry fonts system-wide. It doesn't matter where it is: I've seen them on the log-in screen, Safari, Mail, Xcode, and Skype. Every font is very blurry.

It seems as though a non-native screen resolution is in use, but, in System Preferences, the "built in screen resolution" option is chosen.

I have a 15" MacBook Pro (Model A1286) with the High Resolution panel (1680x1050).

Can someone confirm or help here?

Some screenshots:

enter image description here enter image description here

share|improve this question
    
Open Font Book and see if the Look for Enabled Duplicates command (in the Edit menu) turns up anything. –  robmathers Jul 26 '12 at 21:50
    
"No Duplicates found" "There were no duplicated fonts found on your system." –  itinance Jul 26 '12 at 22:24
    
Can you please post a screenshot of what this looks like? It's hard to diagnose without one. –  jtbandes Jul 27 '12 at 4:33
    
i added screenshots in the main posting –  itinance Jul 27 '12 at 7:56

3 Answers 3

Check if you have enabled:
System Preferences → General → Use LCD font smoothing when available

Without font smoothing: enter image description here

With font smoothing: enter image description here

share|improve this answer
    
thanks for reply! i checked both settings and can't see any difference between them. –  itinance Jul 27 '12 at 8:54
    
@itinance Did you restart the browser or log out and back in? –  gentmatt Jul 27 '12 at 8:58
    
yes, i rebootet the machine –  itinance Jul 27 '12 at 10:31
1  
Thanks, that fixed it for me (after an application restart). I thought it was an option to enable/disable antialiasing. –  Jamie Schembri Jul 28 '12 at 20:29
1  
LCD font smoothing does seem to be enabled in the @itinance's screenshots, because text isn't monochromatic when zoomed in. If toggling the checkbox doesn't have any effect, you could try defaults delete -g AppleFontSmoothing and defaults -currentHost delete -g AppleFontSmoothing and reopening System Preferences (or see my answer). –  Lri Aug 10 '12 at 12:54

Toggling LCD font smoothing (subpixel rendering) should have an immediate effect on the System Preferences window with most displays.

LCD font smoothing is not enabled automatically on some LCD displays though. You might be able to force them to use it with defaults write -g AppleFontSmoothing -int 2, which corresponds to the pre-10.6 medium setting or enabling LCD font smoothing on most displays.

10.5 used to allow choosing from two additional text rendering settings, light and strong. If the default was light before you upgraded to 10.8, you can restore it with defaults write -g AppleFontSmoothing -int 1.

High Resolution Guidelines for OS X: Advanced Optimization Techniques

In OS X v10.8, the default value of the NSFontDefaultScreenFontSubstitutionEnabled setting is NO. This setting determines whether or not text APIs (such as NSLayoutManager, NSCell, and the NSStringDrawing categories on NSString and NSAttributedString) substitute screen fonts when calculating layout and display of text.

Although screen font substitution will no longer be the default, using screen font might still be appropriate to support:

  • Compatibility with documents created with previous versions of your app. The difference in glyph advancement measurements between integral and floating-point values can cause a change in text layout.
  • Fixed-pitch plain text style output—for example, the Plain Text mode in Text Edit. To keep the OS X v10.7 screen font substitution behavior as the default, set the NSUserDefaults key NSFontDefaultScreenFontSubstitutionEnabled to YES.

To maintain the screen font setting on a per-document basis, specify NSUsesScreenFontsDocumentAttribute as a document attribute when you initialize an attributed string object.

defaults write -g NSFontDefaultScreenFontSubstitutionEnabled -bool true didn't seem to have (almost) any effect in most applications. But for some reason it disabled kerning in AppleScript Editor.

share|improve this answer
    
Thanks for a very detailed answer. However, it doesn't actually include how to disable antialising. Do you mind looking at my question, where I explicitly request to have it completely disabled? apple.stackexchange.com/questions/110750/… –  cnst Nov 16 '13 at 5:51

Found the answer here:

http://stackoverflow.com/questions/11660895/disable-anti-aliasing-fonts-in-xcode-4-4-in-mountain-lion

From the Release Notes: https://developer.apple.com/library/mac/#releasenotes/DeveloperTools/RN-Xcode/_index.html#//apple_ref/doc/uid/TP40001051

Text and font rendering on OS X v10.8 is optimized for Retina display. On a non–Retina display running OS X v.10.8, some font configurations can appear blurry in Xcode. 11486875 Switch back to non–Retina display optimized text and font appearance in Xcode by entering this command in Terminal:

defaults write com.apple.dt.Xcode NSFontDefaultScreenFontSubstitutionEnabled -bool YES
share|improve this answer
    
This doesn't seem to work, I'm still getting blurry fonts within Terminal. apple.stackexchange.com/questions/110750/… –  cnst Nov 16 '13 at 5:50

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.