Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I have a mid-2007 MacBook Pro, the one with the trackpad that had the physical button on along the bottom edge. The trackpad is not well and using it can cause it to stick and freak out OS X.

Is there a way to disable the trackpad that's a little more low-level than the method outlined in this question and answer? A BIOS setting perhaps? I'd like the trackpad to never be useable on the unit, whether an external mouse is connected to it or not.

share|improve this question
add comment

1 Answer 1

up vote 2 down vote accepted

You should be able to do this by unloading the kernel extension (kext) that controls the trackpad from the command line.

sudo kextunload /System/Library/Extensions/AppleUSBTopCase.kext/Contents/PlugIns/AppleUSBTrackpad.kext to disable it. Change kextunload to kextload to re-enable it.

When I tested this, it complained that it couldn't unload the kext, but it appeared to disable the trackpad (and it didn't show in System Prefs) despite the warnings.

Warning for Magic Trackpad Users: I don't have a Magic Trackpad, so I don't know whether this kext is responsible for that device or not. Careful testing this out, you may accidentally disable all your mouse inputs at once.

Edit: I did a little more digging, and there is a "AppleBluetoothMultitouch.kext", which sounds like it's responsible for the Magic Trackpad, so it's likely you can disable the internal trackpad independent of any external ones.

share|improve this answer
    
So I'd have to do this every time the machine boots? Or is once enough and it'll stay unloaded between restarts? –  Ian C. Jul 27 '12 at 0:37
    
I didn't do extensive testing, but I think it persists through reboots. It's not a destructive action, so you should be okay just trying yourself. Even if it doesn't persist, you should script it to unload on restart. –  robmathers Jul 27 '12 at 2:20
    
I get an error telling me the extension is in use when I try to unload it. I do have an USB mouse connected to the machine: gist.github.com/3187966 –  Ian C. Jul 27 '12 at 13:22
    
I got those errors too (noted in the 2nd paragraph of my answer), but it seems to work regardless, at least on my machine. –  robmathers Jul 27 '12 at 13:26
    
Ah cool. So yea, it's re-enabled on reboot so I do need to run this on login (or I'll see if I can make it run on startup and have it work). But this is pretty good. –  Ian C. Jul 27 '12 at 13:32
show 3 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.