Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I purchased Mountain Lion on App Store and start downloading. It shows an icon the the task bar and a progress bar on the Mountain Lion logo.

But it just doesn't start download. It has been one hour since it started but the progress bar is still empty.

What is going wrong?

share|improve this question
Check the Purchased tab of the App Store. Any activity there under the OS X Mountain Lion entry? – Nathan Jul 26 '12 at 3:26
Do you have a slow internet connection? Are you using GoogleDNS or OpenDNS? – Gerry Jul 26 '12 at 6:18
up vote 5 down vote accepted

There are two things that come to mind:

  1. The store is so busy that it's not sending the data to your computer to start the download.
  2. The usual things have failed and you can jump start it by following some steps on troubleshooting an App Store download.

Here are the self help steps:

share|improve this answer
you're probably right that it's busy. It just so slow that almost not downloading. Now I see I have 20 hours left... – KMC Jul 26 '12 at 3:44

From reading elsewhere, the solution for me was to go to my "Purchases" section in the AppStore and select "Download" from there. I don't have the Mountain Lion icon, but I can track the download process from App Store.

share|improve this answer

I have the same problem here, i started the download last night at about 9 uk time, just got on the computer to check and its still not responding. Ive tried the a dive from above but its not really done anything,

Update, I've spoken to Apple and they say its because I'm a bt business broadband user, I've also spoken to Bt and its true for me that my business hub only allows a 2 gb download. So now i have to wait for a new hub to arrive... Brill so if your a bt business user this sounds more likely to be this issue. Hope this helps

share|improve this answer
I ran in to the same problem. You just have to wait. i think it's too busy. – KMC Jul 26 '12 at 10:21

In case someone else stumbles across this- I was having the same problem- it was downloading between 0 and 20KBps (after 3 days, it had downloaded almost 2GB).

But thanks to Gerry's question about OpenDNS or GoogleDNS, I tried disabling OpenDNS and it is now downloading at a solid 920KBps (The absolute maximum my internet connection provides).

Thanks Gerry!

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.