Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

When I try to download the Xcode 4.4 update I'm presented with this error:

Xcode can’t be installed on “Mac HD” because the version of OS X is too new.

But the change log says that the update is for Lion and Mountain Lion.

share|improve this question
    
Also deleting Xcode then trying to download from MAS results in the same error. –  Steve Moser Jul 26 '12 at 3:18
    
Can we assume that sw_vers has 10.8 and a build version of 12A269 on your Mac? –  bmike Jul 26 '12 at 3:30
    
Yes, 12A269. So no MAS update for GM? –  Steve Moser Jul 26 '12 at 3:31
    
I have the same issue v4.4 cannot be installed, 12A269 –  aCuria Jul 26 '12 at 7:52

1 Answer 1

up vote 7 down vote accepted

You can manually clear the store where the App Store saves the downloads before completion:

  1. Quit the App Store app
  2. Open Terminal.app (search with Spotlight)
  3. rm -r /private/var/folders/*/*/*/com.apple.appstore

    This step is the removal part...

  4. Restart the App store.app
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.