Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I just upgraded to Mountain Lion, and now gcc, make, g++, etc. are not found when trying to launch them in Terminal.

So I went to Xcode Preferences, Downloads, and clicked "Install" next to Command Line Tools.

It asked me for my Apple ID, which is weird and unnecessary, but I entered it anyway. Note that I am a registered Mac OS X and iOS developer (so I pay 2x $99 per year).

Much to my surprise, it tells me:

enter image description here

Um, what?! And why is it asking?

share|improve this question
    
Typically, the tools are installed as part of the Xcode package in /Applications (or wherever else you have the app itself). If you run xcode-select --print-path does it show the correct location for your Xcode? –  bmike Jul 25 '12 at 18:19
    
@bmike: yes, it shows /Applications/Xcode.app/Contents/Developer as expected. The command line tools actually seem to be in /Applications/Xcode.app/Contents/Developer/usr/bin, can I just add that to my path? If so, why does Xcode say the Command Line Tools are an additional 115.1 MB? –  houbysoft Jul 25 '12 at 18:21
2  
I believe just the essential tools are bundled now and the full set of command line tools are packaged separately. Also, there is this.... stackoverflow.com/questions/9329243/… –  bmike Jul 25 '12 at 18:31
    
@bmike: thanks, the stackoverflow answer worked. Still, I'd like somebody to answer the question as it stands. It's unacceptable if Apple really will officially require a special subscription just to get the tools. –  houbysoft Jul 25 '12 at 18:56
    
Perfect - I don't think it's stupid or unacceptable, but I can see how many might feel that way. My guess is it's unintentional and due to a capacity or server side bug - but only time will tell if this is intended going forward. –  bmike Jul 25 '12 at 18:58
show 1 more comment

1 Answer 1

up vote 4 down vote accepted

It thankfully seems that this was a temporary issue, probably due to the increased load on the Apple servers on Mountain Lion's release day.

I am now able to download the Command Line Tools as before so it seems the issue has gone away.

Alternatively, if you're still having problems, this link worked for me when the "Install" button in Xcode didn't.

share|improve this answer
    
Odd - I've installed Xcode on several Mountain Lion macs and not yet needed to enter any Apple ID other than in the App Store to start the download. Glad it's resolved as a temporary issue on the server side nonetheless. –  bmike Jul 26 '12 at 21:15
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.